CVE-2021-3427
CVE-2021-3427
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The Deluge Web-UI is vulnerable to XSS through a crafted torrent file. The the data from torrent files is not properly sanitised as it's interpreted directly as HTML. Someone who supplies the user with a malicious torrent file can execute arbitrary Javascript code in the context of the user's browser session.
CVSS 6.1 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Affected products and versions
deluge-web
- Versions
- Not-Known: Affected
No fix published
deluge Debian:12
- Versions
- 2.0.3-4
- 2.1.1-1
- 2.1.1-2
- 2.1.1-3
- 2.1.1-4
- 2.1.1-5
- 2.1.2~dev0+20230529-1
- 2.1.2~dev0+20230529-2
- 2.1.2~dev0+20230529-3
- 2.1.2~dev0+20230529-4
- 2.1.2~dev0+20230827-1
- 2.1.2~dev0+20230918-1
- 2.1.2~dev0+20231127-1
- 2.1.2~dev0+20240121-1
- 2.1.2~dev0+20240219-1
- 2.1.2~dev0+20240219-2
- 2.1.2~dev0+20240219-3
- 2.1.2~dev0+20240910-1
- 2.1.2~dev0+20240910-2
- 2.1.2~dev0+20240910-3
- 2.1.2~dev0+20240910-4
- 2.1.2~dev0+20240910-5
- 2.1.2~dev0+20240910-6
- 2.1.2~dev0+20250301-1
- 2.1.2~dev0+20250301-2
- 2.2.0-1
- 2.2.0-2
- 2.2.0-3
- 2.2.1~dev0+20250824-1
- 2.2.1~dev0+20250824-2
- 2.2.1~dev0+20250824-3
- 2.2.1~dev0+20250824-4
- 2.2.1~dev0+20260307-1
- 2.2.1~dev0+20260307-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
deluge Debian:13
- Affected ranges
- ECOSYSTEM: < 2.1.1-4
Update to 2.1.1-4
deluge Debian:14
- Affected ranges
- ECOSYSTEM: < 2.1.1-4
Update to 2.1.1-4
deluge PyPI
- Versions
- 2.0.0
- 2.0.0b2.dev346
- 2.0.0b2.dev347
- 2.0.0b2.dev355
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- Affected ranges
- ECOSYSTEM: < 2.1.0
Update to 2.1.0
deluge Ubuntu:16.04:LTS
- Versions
- 1.3.12-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
deluge Ubuntu:18.04:LTS
- Versions
- 1.3.15-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
deluge Ubuntu:20.04:LTS
- Versions
- 2.0.3-1
- 2.0.3-1.1
- 2.0.3-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
deluge Ubuntu:22.04:LTS
- Versions
- 2.0.3-3.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
deluge Ubuntu:24.04:LTS
- Versions
- 2.1.2~dev0+20230529-4
- 2.1.2~dev0+20230827-1
- 2.1.2~dev0+20230918-1
- 2.1.2~dev0+20231127-1
- 2.1.2~dev0+20240121-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published