CVE-2021-34334
CVE-2021-34334 · Denial of service due to integer overflow in loop counter
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An infinite loop is triggered when Exiv2 is used to read the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. The bug is fixed in version v0.27.5.
CVSS 5.5 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
exiv2
- Versions
- <= 0.27.4: Affected
No fix published
exiv2 Debian:12
- Affected ranges
- ECOSYSTEM: < 0.27.5-1
Update to 0.27.5-1
exiv2 Debian:13
- Affected ranges
- ECOSYSTEM: < 0.27.5-1
Update to 0.27.5-1
exiv2 Debian:14
- Affected ranges
- ECOSYSTEM: < 0.27.5-1
Update to 0.27.5-1
exiv2 Ubuntu:Pro:16.04:LTS
- Versions
- 0.25-1ubuntu1
- 0.25-2.1
- 0.25-2.1ubuntu16.04.1
- 0.25-2.1ubuntu16.04.2
- 0.25-2.1ubuntu16.04.3
- 0.25-2.1ubuntu16.04.4
- 0.25-2.1ubuntu16.04.5
- 0.25-2.1ubuntu16.04.6
- 0.25-2.1ubuntu16.04.7+esm1
- 0.25-2.1ubuntu16.04.7+esm2
- 0.25-2.1ubuntu16.04.7+esm3
- Affected ranges
- ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm4
Update to 0.25-2.1ubuntu16.04.7+esm4
exiv2 Ubuntu:18.04:LTS
- Versions
- 0.25-3.1
- 0.25-3.1ubuntu0.18.04.1
- 0.25-3.1ubuntu0.18.04.2
- 0.25-3.1ubuntu0.18.04.3
- 0.25-3.1ubuntu0.18.04.4
- 0.25-3.1ubuntu0.18.04.5
- 0.25-3.1ubuntu0.18.04.7
- 0.25-3.1ubuntu0.18.04.9
- 0.25-3.1ubuntu0.18.04.10
- Affected ranges
- ECOSYSTEM: < 0.25-3.1ubuntu0.18.04.11
Update to 0.25-3.1ubuntu0.18.04.11
exiv2 Ubuntu:20.04:LTS
- Versions
- 0.25-4ubuntu2
- 0.25-4ubuntu3
- 0.27.2-8ubuntu2
- 0.27.2-8ubuntu2.2
- 0.27.2-8ubuntu2.4
- 0.27.2-8ubuntu2.5
- Affected ranges
- ECOSYSTEM: < 0.27.2-8ubuntu2.6
Update to 0.27.2-8ubuntu2.6
exiv2 Ubuntu:22.04:LTS
- Affected ranges
- ECOSYSTEM: < 0.27.3-3ubuntu4
Update to 0.27.3-3ubuntu4
Original sources
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-hqjh-hpv8-8r9p
- https://github.com/Exiv2/exiv2/pull/1766
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FMDT4PJB7P43WSOM3TRQIY3J33BAFVVE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UYGDELIFFJWKUU7SO3QATCIXCZJERGAC/
- https://lists.debian.org/debian-lts-announce/2023/01/msg00004.html
- https://security.gentoo.org/glsa/202312-06
- https://nvd.nist.gov/vuln/detail/CVE-2021-34334