CVE-2021-3475
CVE-2021-3475
This page contains facts from public vulnerability sources. Check the original advisory before updating.
There is a flaw in OpenEXR in versions before 3.0.0-beta. An attacker who can submit a crafted file to be processed by OpenEXR could cause an integer overflow, potentially leading to problems with application availability.
CVSS 5.3 · Medium · EPSS 1.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
openexr
- Versions
- OpenEXR 3.0.0-beta: Affected
No fix published
openexr Debian:12
- Affected ranges
- ECOSYSTEM: < 2.5.4-1
Update to 2.5.4-1
openexr Debian:13
- Affected ranges
- ECOSYSTEM: < 2.5.4-1
Update to 2.5.4-1
openexr Debian:14
- Affected ranges
- ECOSYSTEM: < 2.5.4-1
Update to 2.5.4-1
openexr Ubuntu:16.04:LTS
- Versions
- 2.2.0-1ubuntu3
- 2.2.0-7ubuntu1
- 2.2.0-9ubuntu1
- 2.2.0-10ubuntu2
- 2.2.0-10ubuntu2.1
- 2.2.0-10ubuntu2.2
- 2.2.0-10ubuntu2.3
- 2.2.0-10ubuntu2.4
- Affected ranges
- ECOSYSTEM: < 2.2.0-10ubuntu2.6
Update to 2.2.0-10ubuntu2.6
openexr Ubuntu:18.04:LTS
- Versions
- 2.2.0-11ubuntu1
- 2.2.0-11.1ubuntu1
- 2.2.0-11.1ubuntu1.1
- 2.2.0-11.1ubuntu1.2
- 2.2.0-11.1ubuntu1.3
- 2.2.0-11.1ubuntu1.4
- Affected ranges
- ECOSYSTEM: < 2.2.0-11.1ubuntu1.6
Update to 2.2.0-11.1ubuntu1.6
openexr Ubuntu:20.04:LTS
- Versions
- 2.2.1-4.1ubuntu1
- 2.3.0-6
- 2.3.0-6build1
- 2.3.0-6ubuntu0.1
- 2.3.0-6ubuntu0.2
- 2.3.0-6ubuntu0.3
- Affected ranges
- ECOSYSTEM: < 2.3.0-6ubuntu0.5
Update to 2.3.0-6ubuntu0.5
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=1939144
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=25297
- https://lists.debian.org/debian-lts-announce/2021/07/msg00001.html
- https://security.gentoo.org/glsa/202107-27
- https://lists.debian.org/debian-lts-announce/2022/12/msg00022.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-3475