CVE-2021-3546
CVE-2021-3546
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An out-of-bounds write vulnerability was found in the virtio vhost-user GPU device (vhost-user-gpu) of QEMU in versions up to and including 6.0. The flaw occurs while processing the 'VIRTIO_GPU_CMD_GET_CAPSET' command from the guest. It could allow a privileged guest user to crash the QEMU process on the host, resulting in a denial of service condition, or potential code execution with the privileges of the QEMU process.
CVSS 8.2 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
qemu
- Versions
- All QEMU versions up to and including 6.0: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 1:6.1+dfsg-1
Update to 1:6.1+dfsg-1
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 1:6.1+dfsg-1
Update to 1:6.1+dfsg-1
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 1:6.1+dfsg-1
Update to 1:6.1+dfsg-1
qemu Ubuntu:20.04:LTS
- Versions
- 1:4.0+dfsg-0ubuntu9
- 1:4.0+dfsg-0ubuntu10
- 1:4.2-1ubuntu1
- 1:4.2-1ubuntu2
- 1:4.2-3ubuntu1
- 1:4.2-3ubuntu2
- 1:4.2-3ubuntu3
- 1:4.2-3ubuntu4
- 1:4.2-3ubuntu5
- 1:4.2-3ubuntu6
- 1:4.2-3ubuntu6.1
- 1:4.2-3ubuntu6.2
- 1:4.2-3ubuntu6.3
- 1:4.2-3ubuntu6.4
- 1:4.2-3ubuntu6.5
- 1:4.2-3ubuntu6.6
- 1:4.2-3ubuntu6.7
- 1:4.2-3ubuntu6.8
- 1:4.2-3ubuntu6.9
- 1:4.2-3ubuntu6.10
- 1:4.2-3ubuntu6.11
- 1:4.2-3ubuntu6.12
- 1:4.2-3ubuntu6.14
- 1:4.2-3ubuntu6.15
- 1:4.2-3ubuntu6.16
- Affected ranges
- ECOSYSTEM: < 1:4.2-3ubuntu6.17
Update to 1:4.2-3ubuntu6.17
qemu Ubuntu:22.04:LTS
- Versions
- 1:6.0+dfsg-2expubuntu1
- 1:6.0+dfsg-2expubuntu2
- 1:6.0+dfsg-2expubuntu4
- Affected ranges
- ECOSYSTEM: < 1:6.2+dfsg-2ubuntu5
Update to 1:6.2+dfsg-2ubuntu5