CVE-2021-35513
CVE-2021-35513
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Mermaid before 8.11.0 allows XSS when the antiscript feature is used.
CVSS 6.1 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
node-mermaid Debian:14
- Versions
- 8.7.0+ds+~cs27.17.17-1
- 8.7.0+ds+~cs27.17.17-2
- 8.7.0+ds+~cs27.17.17-2~bpo10+1
- Affected ranges
- ECOSYSTEM: < 8.7.0+ds+~cs27.17.17-3
Update to 8.7.0+ds+~cs27.17.17-3
mermaid npm
- Affected ranges
- SEMVER: < 8.11.0
Update to 8.11.0
node-mermaid Ubuntu:22.04:LTS
- Versions
- 8.7.0+ds+~cs27.17.17-3
- 8.13.3+ds+~cs26.13.21-1
- 8.13.3+ds+~cs26.13.21-2
- 8.13.8+~cs10.4.16-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-mermaid Ubuntu:26.10
- Versions
- 9.2.2+~2.0.0-1
- 9.2.2+~2.0.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published