CVE-2021-3598
CVE-2021-3598
This page contains facts from public vulnerability sources. Check the original advisory before updating.
There's a flaw in OpenEXR's ImfDeepScanLineInputFile functionality in versions prior to 3.0.5. An attacker who is able to submit a crafted file to an application linked with OpenEXR could cause an out-of-bounds read. The greatest risk from this flaw is to application availability.
CVSS 5.5 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
openexr
- Versions
- OpenEXR 3.0.5: Affected
No fix published
openexr Debian:12
- Affected ranges
- ECOSYSTEM: < 2.5.7-1
Update to 2.5.7-1
openexr Debian:13
- Affected ranges
- ECOSYSTEM: < 2.5.7-1
Update to 2.5.7-1
openexr Debian:14
- Affected ranges
- ECOSYSTEM: < 2.5.7-1
Update to 2.5.7-1
openexr Ubuntu:Pro:16.04:LTS
- Versions
- 2.2.0-1ubuntu3
- 2.2.0-7ubuntu1
- 2.2.0-9ubuntu1
- 2.2.0-10ubuntu2
- 2.2.0-10ubuntu2.1
- 2.2.0-10ubuntu2.2
- 2.2.0-10ubuntu2.3
- 2.2.0-10ubuntu2.4
- 2.2.0-10ubuntu2.6
- Affected ranges
- ECOSYSTEM: < 2.2.0-10ubuntu2.6+esm1
Update to 2.2.0-10ubuntu2.6+esm1
openexr Ubuntu:18.04:LTS
- Versions
- 2.2.0-11ubuntu1
- 2.2.0-11.1ubuntu1
- 2.2.0-11.1ubuntu1.1
- 2.2.0-11.1ubuntu1.2
- 2.2.0-11.1ubuntu1.3
- 2.2.0-11.1ubuntu1.4
- 2.2.0-11.1ubuntu1.6
- Affected ranges
- ECOSYSTEM: < 2.2.0-11.1ubuntu1.7
Update to 2.2.0-11.1ubuntu1.7
openexr Ubuntu:Pro:20.04:LTS
- Versions
- 2.2.1-4.1ubuntu1
- 2.3.0-6
- 2.3.0-6build1
- 2.3.0-6ubuntu0.1
- 2.3.0-6ubuntu0.2
- 2.3.0-6ubuntu0.3
- 2.3.0-6ubuntu0.5
- Affected ranges
- ECOSYSTEM: < 2.3.0-6ubuntu0.5+esm1
Update to 2.3.0-6ubuntu0.5+esm1