p PatchFirst

CVE-2021-3608

CVE-2021-3608

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in the QEMU implementation of VMWare's paravirtual RDMA device in versions prior to 6.1.0. The issue occurs while handling a "PVRDMA_REG_DSRHIGH" write from the guest and may result in a crash of QEMU or cause undefined behavior due to the access of an uninitialized pointer. The highest threat from this vulnerability is to system availability.

CVSS 6.0 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • qemu

    Versions
    • qemu-kvm 6.1.0: Affected

    No fix published

  • qemu Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:5.2+dfsg-11

    Update to 1:5.2+dfsg-11

  • qemu Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:5.2+dfsg-11

    Update to 1:5.2+dfsg-11

  • qemu Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:5.2+dfsg-11

    Update to 1:5.2+dfsg-11

  • qemu Ubuntu:20.04:LTS

    Versions
    • 1:4.0+dfsg-0ubuntu9
    • 1:4.0+dfsg-0ubuntu10
    • 1:4.2-1ubuntu1
    • 1:4.2-1ubuntu2
    • 1:4.2-3ubuntu1
    • 1:4.2-3ubuntu2
    • 1:4.2-3ubuntu3
    • 1:4.2-3ubuntu4
    • 1:4.2-3ubuntu5
    • 1:4.2-3ubuntu6
    • 1:4.2-3ubuntu6.1
    • 1:4.2-3ubuntu6.2
    • 1:4.2-3ubuntu6.3
    • 1:4.2-3ubuntu6.4
    • 1:4.2-3ubuntu6.5
    • 1:4.2-3ubuntu6.6
    • 1:4.2-3ubuntu6.7
    • 1:4.2-3ubuntu6.8
    • 1:4.2-3ubuntu6.9
    • 1:4.2-3ubuntu6.10
    • 1:4.2-3ubuntu6.11
    • 1:4.2-3ubuntu6.12
    • 1:4.2-3ubuntu6.14
    • 1:4.2-3ubuntu6.15
    • 1:4.2-3ubuntu6.16
    Affected ranges
    • ECOSYSTEM: < 1:4.2-3ubuntu6.17

    Update to 1:4.2-3ubuntu6.17

  • qemu Ubuntu:22.04:LTS

    Affected ranges
    • ECOSYSTEM: < 1:6.0+dfsg-2expubuntu1

    Update to 1:6.0+dfsg-2expubuntu1

Original sources

Check your server →