CVE-2021-3621
CVE-2021-3621
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in SSSD, where the sssctl command was vulnerable to shell command injection via the logs-fetch and cache-expire subcommands. This flaw allows an attacker to trick the root user into running a specially crafted sssctl command, such as via sudo, to gain root access. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
CVSS 8.8 · High · EPSS 2.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
sssd
- Versions
- sssd 2.6.0: Affected
No fix published
sssd Debian:12
- Affected ranges
- ECOSYSTEM: < 2.5.2-1
Update to 2.5.2-1
sssd Debian:13
- Affected ranges
- ECOSYSTEM: < 2.5.2-1
Update to 2.5.2-1
sssd Ubuntu:18.04:LTS
- Versions
- 1.15.3-2ubuntu1
- 1.15.3-3ubuntu1
- 1.16.0-5ubuntu1
- 1.16.0-5ubuntu2
- 1.16.1-1ubuntu1
- 1.16.1-1ubuntu1.1
- 1.16.1-1ubuntu1.2
- 1.16.1-1ubuntu1.3
- 1.16.1-1ubuntu1.4
- 1.16.1-1ubuntu1.5
- 1.16.1-1ubuntu1.6
- 1.16.1-1ubuntu1.7
- Affected ranges
- ECOSYSTEM: < 1.16.1-1ubuntu1.8
Update to 1.16.1-1ubuntu1.8
sssd Ubuntu:20.04:LTS
- Versions
- 2.2.0-4ubuntu1
- 2.2.2-1
- 2.2.2-1ubuntu1
- 2.2.3-1.1ubuntu1
- 2.2.3-2
- 2.2.3-3
- 2.2.3-3ubuntu0.1
- 2.2.3-3ubuntu0.2
- 2.2.3-3ubuntu0.3
- 2.2.3-3ubuntu0.4
- 2.2.3-3ubuntu0.6
- Affected ranges
- ECOSYSTEM: < 2.2.3-3ubuntu0.7
Update to 2.2.3-3ubuntu0.7
sssd Ubuntu:22.04:LTS
- Affected ranges
- ECOSYSTEM: < 2.4.1-2ubuntu4
Update to 2.4.1-2ubuntu4