p PatchFirst

CVE-2021-37622

CVE-2021-37622 · Denial of service due to infinite loop in JpegBase::printStructure (#1)

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An infinite loop was found in Exiv2 versions v0.27.4 and earlier. The infinite loop is triggered when Exiv2 is used to modify the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when deleting the IPTC data, which is a less frequently used Exiv2 operation that requires an extra command line option (`-d I rm`). The bug is fixed in version v0.27.5.

CVSS 5.5 · Medium · EPSS 1.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • exiv2

    Versions
    • <= 0.27.4: Affected

    No fix published

  • exiv2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.27.5-1

    Update to 0.27.5-1

  • exiv2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.27.5-1

    Update to 0.27.5-1

  • exiv2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.27.5-1

    Update to 0.27.5-1

  • exiv2 Ubuntu:Pro:16.04:LTS

    Versions
    • 0.25-1ubuntu1
    • 0.25-2.1
    • 0.25-2.1ubuntu16.04.1
    • 0.25-2.1ubuntu16.04.2
    • 0.25-2.1ubuntu16.04.3
    • 0.25-2.1ubuntu16.04.4
    • 0.25-2.1ubuntu16.04.5
    • 0.25-2.1ubuntu16.04.6
    • 0.25-2.1ubuntu16.04.7+esm1
    • 0.25-2.1ubuntu16.04.7+esm2
    • 0.25-2.1ubuntu16.04.7+esm3
    Affected ranges
    • ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm4

    Update to 0.25-2.1ubuntu16.04.7+esm4

  • exiv2 Ubuntu:18.04:LTS

    Versions
    • 0.25-3.1
    • 0.25-3.1ubuntu0.18.04.1
    • 0.25-3.1ubuntu0.18.04.2
    • 0.25-3.1ubuntu0.18.04.3
    • 0.25-3.1ubuntu0.18.04.4
    • 0.25-3.1ubuntu0.18.04.5
    • 0.25-3.1ubuntu0.18.04.7
    • 0.25-3.1ubuntu0.18.04.9
    • 0.25-3.1ubuntu0.18.04.10
    Affected ranges
    • ECOSYSTEM: < 0.25-3.1ubuntu0.18.04.11

    Update to 0.25-3.1ubuntu0.18.04.11

  • exiv2 Ubuntu:20.04:LTS

    Versions
    • 0.25-4ubuntu2
    • 0.25-4ubuntu3
    • 0.27.2-8ubuntu2
    • 0.27.2-8ubuntu2.2
    • 0.27.2-8ubuntu2.4
    • 0.27.2-8ubuntu2.5
    Affected ranges
    • ECOSYSTEM: < 0.27.2-8ubuntu2.6

    Update to 0.27.2-8ubuntu2.6

  • exiv2 Ubuntu:22.04:LTS

    Affected ranges
    • ECOSYSTEM: < 0.27.3-3ubuntu4

    Update to 0.27.3-3ubuntu4

Original sources

Check your server →