CVE-2021-37682
CVE-2021-37682 · Use of unitialized value in TensorFlow Lite
This page contains facts from public vulnerability sources. Check the original advisory before updating.
TensorFlow is an end-to-end open source platform for machine learning. In affected versions all TFLite operations that use quantization can be made to use unitialized values. [For example](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/lite/kernels/depthwise_conv.cc#L198-L200). The issue stems from the fact that `quantization.params` is only valid if `quantization.type` is different that `kTfLiteNoQuantization`. However, these checks are missing in large parts of the code. We have patched the issue in GitHub commits 537bc7c723439b9194a358f64d871dd326c18887, 4a91f2069f7145aab6ba2d8cfe41be8a110c18a5 and 8933b8a21280696ab119b63263babdb54c298538. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.
CVSS 4.4 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
tensorflow
- Versions
- >= 2.5.0, < 2.5.1: Affected
- >= 2.4.0, < 2.4.3: Affected
- < 2.3.4: Affected
No fix published
tensorflow PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- Affected ranges
- ECOSYSTEM: < 2.3.4
Update to 2.3.4
tensorflow PyPI
- Versions
- 2.4.0
- 2.4.1
- 2.4.2
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.3
Update to 2.4.3
tensorflow PyPI
- Versions
- 2.5.0
- Affected ranges
- ECOSYSTEM: ≥ 2.5.0, < 2.5.1
Update to 2.5.1
tensorflow-cpu PyPI
- Versions
- 1.15.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- Affected ranges
- ECOSYSTEM: < 2.3.4
Update to 2.3.4
tensorflow-cpu PyPI
- Versions
- 2.4.0
- 2.4.1
- 2.4.2
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.3
Update to 2.4.3
tensorflow-cpu PyPI
- Versions
- 2.5.0
- Affected ranges
- ECOSYSTEM: ≥ 2.5.0, < 2.5.1
Update to 2.5.1
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- Affected ranges
- ECOSYSTEM: < 2.3.4
Update to 2.3.4
tensorflow-gpu PyPI
- Versions
- 2.4.0
- 2.4.1
- 2.4.2
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.3
Update to 2.4.3
tensorflow-gpu PyPI
- Versions
- 2.5.0
- Affected ranges
- ECOSYSTEM: ≥ 2.5.0, < 2.5.1
Update to 2.5.1
tensorflow PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.4.0
- 2.4.1
- 2.4.2
- Affected ranges
- {"events": [{"introduced": "0"}, {"fixed": "537bc7c723439b9194a358f64d871dd326c18887"}, {"fixed": "4a91f2069f7145aab6ba2d8cfe41be8a110c18a5"}, {"fixed": "8933b8a21280696ab119b63263babdb54c298538"}], "repo": "https://github.com/tensorflow/tensorflow", "type": "GIT"}
- ECOSYSTEM: ≥ 2.3.0, < 2.3.4 ∪ ≥ 2.4.0, < 2.4.3
Update to 2.3.4; Update to 2.4.3
tensorflow-cpu PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.4.0
- 2.4.1
- 2.4.2
- Affected ranges
- {"events": [{"introduced": "0"}, {"fixed": "537bc7c723439b9194a358f64d871dd326c18887"}, {"fixed": "4a91f2069f7145aab6ba2d8cfe41be8a110c18a5"}, {"fixed": "8933b8a21280696ab119b63263babdb54c298538"}], "repo": "https://github.com/tensorflow/tensorflow", "type": "GIT"}
- ECOSYSTEM: ≥ 2.3.0, < 2.3.4 ∪ ≥ 2.4.0, < 2.4.3
Update to 2.3.4; Update to 2.4.3
tensorflow-gpu PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.4.0
- 2.4.1
- 2.4.2
- Affected ranges
- {"events": [{"introduced": "0"}, {"fixed": "537bc7c723439b9194a358f64d871dd326c18887"}, {"fixed": "4a91f2069f7145aab6ba2d8cfe41be8a110c18a5"}, {"fixed": "8933b8a21280696ab119b63263babdb54c298538"}], "repo": "https://github.com/tensorflow/tensorflow", "type": "GIT"}
- ECOSYSTEM: ≥ 2.3.0, < 2.3.4 ∪ ≥ 2.4.0, < 2.4.3
Update to 2.3.4; Update to 2.4.3
Original sources
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-4c4g-crqm-xrxw
- https://github.com/tensorflow/tensorflow/commit/4a91f2069f7145aab6ba2d8cfe41be8a110c18a5
- https://github.com/tensorflow/tensorflow/commit/537bc7c723439b9194a358f64d871dd326c18887
- https://github.com/tensorflow/tensorflow/commit/8933b8a21280696ab119b63263babdb54c298538
- https://nvd.nist.gov/vuln/detail/CVE-2021-37682