CVE-2021-37686
CVE-2021-37686 · Infinite loop in TensorFlow Lite
This page contains facts from public vulnerability sources. Check the original advisory before updating.
TensorFlow is an end-to-end open source platform for machine learning. In affected versions the strided slice implementation in TFLite has a logic bug which can allow an attacker to trigger an infinite loop. This arises from newly introduced support for [ellipsis in axis definition](https://github.com/tensorflow/tensorflow/blob/149562d49faa709ea80df1d99fc41d005b81082a/tensorflow/lite/kernels/strided_slice.cc#L103-L122). An attacker can craft a model such that `ellipsis_end_idx` is smaller than `i` (e.g., always negative). In this case, the inner loop does not increase `i` and the `continue` statement causes execution to skip over the preincrement at the end of the outer loop. We have patched the issue in GitHub commit dfa22b348b70bb89d6d6ec0ff53973bacb4f4695. TensorFlow 2.6.0 is the only affected version.
CVSS 5.5 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
tensorflow
- Versions
- >= 2.6.0rc0, < 2.6.0rc2: Affected
No fix published
tensorflow PyPI
- Versions
- 2.6.0rc0
- 2.6.0rc1
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0rc0, < 2.6.0rc2
Update to 2.6.0rc2
tensorflow-cpu PyPI
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0rc0, < 2.6.0rc2
Update to 2.6.0rc2
tensorflow-gpu PyPI
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0rc0, < 2.6.0rc2
Update to 2.6.0rc2
tensorflow PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.4.0
- 2.4.1
- 2.4.2
- Affected ranges
- GIT: < dfa22b348b70bb89d6d6ec0ff53973bacb4f4695
- ECOSYSTEM: ≥ 2.3.0, < 2.3.4 ∪ ≥ 2.4.0, < 2.4.3
Update to 2.3.4; Update to 2.4.3
tensorflow-cpu PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.4.0
- 2.4.1
- 2.4.2
- Affected ranges
- GIT: < dfa22b348b70bb89d6d6ec0ff53973bacb4f4695
- ECOSYSTEM: ≥ 2.3.0, < 2.3.4 ∪ ≥ 2.4.0, < 2.4.3
Update to 2.3.4; Update to 2.4.3
tensorflow-gpu PyPI
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.4.0
- 2.4.1
- 2.4.2
- Affected ranges
- GIT: < dfa22b348b70bb89d6d6ec0ff53973bacb4f4695
- ECOSYSTEM: ≥ 2.3.0, < 2.3.4 ∪ ≥ 2.4.0, < 2.4.3
Update to 2.3.4; Update to 2.4.3