p PatchFirst

CVE-2021-37688

CVE-2021-37688 · Null pointer dereference in TensorFlow Lite

This page contains facts from public vulnerability sources. Check the original advisory before updating.

TensorFlow is an end-to-end open source platform for machine learning. In affected versions an attacker can craft a TFLite model that would trigger a null pointer dereference, which would result in a crash and denial of service. The [implementation](https://github.com/tensorflow/tensorflow/blob/149562d49faa709ea80df1d99fc41d005b81082a/tensorflow/lite/kernels/internal/optimized/optimized_ops.h#L268-L285) unconditionally dereferences a pointer. We have patched the issue in GitHub commit 15691e456c7dc9bd6be203b09765b063bf4a380c. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

CVSS 7.8 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • tensorflow

    Versions
    • >= 2.5.0, < 2.5.1: Affected
    • >= 2.4.0, < 2.4.3: Affected
    • < 2.3.4: Affected

    No fix published

  • tensorflow PyPI

    Versions
    • 0.12.0
    • 0.12.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.10.0
    • 1.10.1
    • 1.11.0
    • 1.12.0
    • 1.12.2
    • 1.12.3
    • 1.13.1
    • 1.13.2
    • 1.14.0
    • 1.15.0
    • 1.15.2
    • 1.15.3
    • 1.15.4
    • 1.15.5
    • 1.2.0
    • 1.2.1
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.5.1
    • 1.6.0
    • 1.7.0
    • 1.7.1
    • 1.8.0
    • 1.9.0
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    Affected ranges
    • ECOSYSTEM: < 2.3.4

    Update to 2.3.4

  • tensorflow PyPI

    Versions
    • 2.4.0
    • 2.4.1
    • 2.4.2
    Affected ranges
    • ECOSYSTEM: ≥ 2.4.0, < 2.4.3

    Update to 2.4.3

  • tensorflow PyPI

    Versions
    • 2.5.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.5.0, < 2.5.1

    Update to 2.5.1

  • tensorflow-cpu PyPI

    Versions
    • 2.5.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.5.0, < 2.5.1

    Update to 2.5.1

  • tensorflow-cpu PyPI

    Versions
    • 2.4.0
    • 2.4.1
    • 2.4.2
    Affected ranges
    • ECOSYSTEM: ≥ 2.4.0, < 2.4.3

    Update to 2.4.3

  • tensorflow-cpu PyPI

    Versions
    • 1.15.0
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    Affected ranges
    • ECOSYSTEM: < 2.3.4

    Update to 2.3.4

  • tensorflow-gpu PyPI

    Versions
    • 0.12.0
    • 0.12.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.10.0
    • 1.10.1
    • 1.11.0
    • 1.12.0
    • 1.12.2
    • 1.12.3
    • 1.13.1
    • 1.13.2
    • 1.14.0
    • 1.15.0
    • 1.15.2
    • 1.15.3
    • 1.15.4
    • 1.15.5
    • 1.2.0
    • 1.2.1
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.5.1
    • 1.6.0
    • 1.7.0
    • 1.7.1
    • 1.8.0
    • 1.9.0
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    Affected ranges
    • ECOSYSTEM: < 2.3.4

    Update to 2.3.4

  • tensorflow-gpu PyPI

    Versions
    • 2.4.0
    • 2.4.1
    • 2.4.2
    Affected ranges
    • ECOSYSTEM: ≥ 2.4.0, < 2.4.3

    Update to 2.4.3

  • tensorflow-gpu PyPI

    Versions
    • 2.5.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.5.0, < 2.5.1

    Update to 2.5.1

  • tensorflow PyPI

    Versions
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.4.0
    • 2.4.1
    • 2.4.2
    Affected ranges
    • GIT: < 15691e456c7dc9bd6be203b09765b063bf4a380c
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.4 ∪ ≥ 2.4.0, < 2.4.3

    Update to 2.3.4; Update to 2.4.3

  • tensorflow-cpu PyPI

    Versions
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.4.0
    • 2.4.1
    • 2.4.2
    Affected ranges
    • GIT: < 15691e456c7dc9bd6be203b09765b063bf4a380c
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.4 ∪ ≥ 2.4.0, < 2.4.3

    Update to 2.3.4; Update to 2.4.3

  • tensorflow-gpu PyPI

    Versions
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.4.0
    • 2.4.1
    • 2.4.2
    Affected ranges
    • GIT: < 15691e456c7dc9bd6be203b09765b063bf4a380c
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.4 ∪ ≥ 2.4.0, < 2.4.3

    Update to 2.3.4; Update to 2.4.3

Original sources

Check your server →