CVE-2021-37937
CVE-2021-37937 · Elasticsearch privilege escalation
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was found with how API keys are created with the Fleet-Server service account. When an API key is created with a service account, it is possible that the API key could be created with higher privileges than intended. Using this vulnerability, a compromised Fleet-Server service account could escalate themselves to a super-user.
CVSS 5.9 · Medium · EPSS 0.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
elasticsearch
- Versions
- ≥ 7.13.0, < 7.14.0: Affected (semver)
Update to 7.14.0
elasticsearch Ubuntu:16.04:LTS
- Versions
- 1.6.2+dfsg-1
- 1.7.3+dfsg-1
- 1.7.3+dfsg-2
- 1.7.3+dfsg-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published