CVE-2021-3800
CVE-2021-3800
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in glib before version 2.63.6. Due to random charset alias, pkexec can leak content from files owned by privileged users to unprivileged ones under the right condition.
CVSS 5.5 · Medium · EPSS 0.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
glib
- Versions
- Fixed in glib2 2.63.6: Affected
No fix published
glib2.0 Debian:12
- Affected ranges
- ECOSYSTEM: < 2.64.0-1
Update to 2.64.0-1
glib2.0 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.64.0-1
Update to 2.64.0-1
glib2.0 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.64.0-1
Update to 2.64.0-1
glib2.0 Ubuntu:Pro:14.04:LTS
- Versions
- 2.38.0-1ubuntu1
- 2.38.1-1
- 2.39.1-0ubuntu1
- 2.39.1-0ubuntu2
- 2.39.1-0ubuntu3
- 2.39.2-0ubuntu1
- 2.39.2-0ubuntu2
- 2.39.3-0ubuntu4
- 2.39.4-0ubuntu1
- 2.39.90-0ubuntu1
- 2.39.91-0ubuntu2
- 2.39.91-0ubuntu3
- 2.39.92-2
- 2.40.0-1
- 2.40.0-1ubuntu1
- 2.40.0-2
- 2.40.2-0ubuntu1
- 2.40.2-0ubuntu1.1
- 2.40.2-0ubuntu1.1+esm1
- 2.40.2-0ubuntu1.1+esm2
- 2.40.2-0ubuntu1.1+esm3
- Affected ranges
- ECOSYSTEM: < 2.40.2-0ubuntu1.1+esm4
Update to 2.40.2-0ubuntu1.1+esm4
glib2.0 Ubuntu:Pro:16.04:LTS
- Versions
- 2.46.1-1
- 2.46.1-2
- 2.47.1-1
- 2.47.3-3
- 2.47.4-1
- 2.47.5-1
- 2.47.6-1
- 2.48.0-1ubuntu3
- 2.48.0-1ubuntu4
- 2.48.1-1~ubuntu16.04.1
- 2.48.2-0ubuntu1
- 2.48.2-0ubuntu3
- 2.48.2-0ubuntu4
- 2.48.2-0ubuntu4.1
- 2.48.2-0ubuntu4.2
- 2.48.2-0ubuntu4.3
- 2.48.2-0ubuntu4.4
- 2.48.2-0ubuntu4.5
- 2.48.2-0ubuntu4.6
- 2.48.2-0ubuntu4.7
- 2.48.2-0ubuntu4.8
- Affected ranges
- ECOSYSTEM: < 2.48.2-0ubuntu4.8+esm1
Update to 2.48.2-0ubuntu4.8+esm1
glib2.0 Ubuntu:18.04:LTS
- Versions
- 2.54.1-1ubuntu1
- 2.55.2-2ubuntu1
- 2.56.0-2ubuntu1
- 2.56.0-4ubuntu1
- 2.56.1-2ubuntu1
- 2.56.2-0ubuntu0.18.04.1
- 2.56.2-0ubuntu0.18.04.2
- 2.56.3-0ubuntu0.18.04.1
- 2.56.4-0ubuntu0.18.04.2
- 2.56.4-0ubuntu0.18.04.3
- 2.56.4-0ubuntu0.18.04.4
- 2.56.4-0ubuntu0.18.04.5
- 2.56.4-0ubuntu0.18.04.6
- 2.56.4-0ubuntu0.18.04.7
- 2.56.4-0ubuntu0.18.04.8
- Affected ranges
- ECOSYSTEM: < 2.56.4-0ubuntu0.18.04.9
Update to 2.56.4-0ubuntu0.18.04.9
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=1938284
- https://access.redhat.com/security/cve/CVE-2021-3800
- https://www.openwall.com/lists/oss-security/2017/06/23/8
- https://gitlab.gnome.org/GNOME/glib/-/commit/3529bb4450a51995
- https://lists.debian.org/debian-lts-announce/2022/09/msg00020.html
- https://security.netapp.com/advisory/ntap-20221028-0004/
- https://nvd.nist.gov/vuln/detail/CVE-2021-3800