CVE-2021-3828
CVE-2021-3828 · Inefficient Regular Expression Complexity in nltk/nltk
This page contains facts from public vulnerability sources. Check the original advisory before updating.
nltk is vulnerable to Inefficient Regular Expression Complexity
CVSS 7.5 · High · EPSS 1.6% · Fix available
- Published
- Updated
Affected products and versions
nltk/nltk
- Versions
- ≥ unspecified, ≤ 3.6.3: Affected (custom)
No fix published
nltk Debian:12
- Affected ranges
- ECOSYSTEM: < 3.6.5-1
Update to 3.6.5-1
nltk Debian:13
- Affected ranges
- ECOSYSTEM: < 3.6.5-1
Update to 3.6.5-1
nltk Debian:14
- Affected ranges
- ECOSYSTEM: < 3.6.5-1
Update to 3.6.5-1
nltk PyPI
- Versions
- 0.8
- 0.9
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 0.9.7
- 0.9.8
- 0.9.9
- 2.0.1
- 2.0.1rc1
- 2.0.1rc2-git
- 2.0.1rc3
- 2.0.1rc4
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0b4
- 2.0b5
- 2.0b6
- 2.0b7
- 2.0b8
- 2.0b9
- 3.0.0
- 3.0.0b1
- 3.0.0b2
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 3.0.5
- 3.1
- 3.2
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.3
- 3.4
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.5
- 3.5b1
- 3.6
- 3.6.1
- 3.6.2
- 3.6.3
- Affected ranges
- ECOSYSTEM: < 3.6.4
Update to 3.6.4
nltk PyPI
- Versions
- 0.8
- 0.9
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 0.9.7
- 0.9.8
- 0.9.9
- 2.0.1
- 2.0.1rc1
- 2.0.1rc2-git
- 2.0.1rc3
- 2.0.1rc4
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0b4
- 2.0b5
- 2.0b6
- 2.0b7
- 2.0b8
- 2.0b9
- 3.0.0
- 3.0.0b1
- 3.0.0b2
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 3.0.5
- 3.1
- 3.2
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.3
- 3.4
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.5
- 3.5b1
- 3.6
- 3.6.1
- 3.6.2
- 3.6.3
- Affected ranges
- GIT: < 277711ab1dec729e626b27aab6fa35ea5efbd7e6
- ECOSYSTEM: < 3.6.4
Update to 3.6.4
nltk Ubuntu:Pro:16.04:LTS
- Versions
- 3.0.4-1
- 3.0.5-1
- 3.1-1
- 3.1-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 3.1-1ubuntu0.1+esm1
Update to 3.1-1ubuntu0.1+esm1
nltk Ubuntu:Pro:18.04:LTS
- Versions
- 3.2.4-1
- 3.2.5-1
- 3.2.5-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 3.2.5-1ubuntu0.1+esm1
Update to 3.2.5-1ubuntu0.1+esm1
nltk Ubuntu:Pro:20.04:LTS
- Versions
- 3.4.5-1
- 3.4.5-2
- Affected ranges
- ECOSYSTEM: < 3.4.5-2ubuntu0.1~esm1
Update to 3.4.5-2ubuntu0.1~esm1
nltk Ubuntu:22.04:LTS
- Versions
- 3.5-1
- Affected ranges
- ECOSYSTEM: < 3.6.5-1
Update to 3.6.5-1