CVE-2021-3850
CVE-2021-3850 · Authentication Bypass by Primary Weakness in adodb/adodb
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Authentication Bypass by Primary Weakness in GitHub repository adodb/adodb prior to 5.20.21.
CVSS 9.1 · Critical · EPSS 2.2% · Fix available
- Published
- Updated
Affected products and versions
adodb/adodb
- Versions
- ≥ unspecified, < 5.20.21: Affected (custom)
Update to 5.20.21
libphp-adodb Debian:12
- Affected ranges
- ECOSYSTEM: < 5.21.4-1
Update to 5.21.4-1
libphp-adodb Debian:13
- Affected ranges
- ECOSYSTEM: < 5.21.4-1
Update to 5.21.4-1
libphp-adodb Debian:14
- Affected ranges
- ECOSYSTEM: < 5.21.4-1
Update to 5.21.4-1
adodb/adodb-php Packagist
- Versions
- v5.19
- v5.20.0
- v5.20.1
- v5.20.10
- v5.20.11
- v5.20.12
- v5.20.13
- v5.20.14
- v5.20.15
- v5.20.16
- v5.20.17
- v5.20.18
- v5.20.19
- v5.20.2
- v5.20.20
- v5.20.3
- v5.20.4
- v5.20.5
- v5.20.6
- v5.20.7
- v5.20.8
- v5.20.9
- Affected ranges
- ECOSYSTEM: < 5.20.21
Update to 5.20.21
adodb/adodb-php Packagist
- Versions
- v5.21.0
- v5.21.1
- v5.21.2
- v5.21.3
- Affected ranges
- ECOSYSTEM: ≥ 5.21.0, < 5.21.4
Update to 5.21.4
libphp-adodb Ubuntu:Pro:16.04:LTS
- Versions
- 5.18a-1
- 5.20.1-1
- 5.20.2-1
- 5.20.2-2
- 5.20.3-1
- 5.20.3-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 5.20.3-1ubuntu1+esm1
Update to 5.20.3-1ubuntu1+esm1
libphp-adodb Ubuntu:Pro:18.04:LTS
- Versions
- 5.20.9-1
- Affected ranges
- ECOSYSTEM: < 5.20.9-1ubuntu0.1~esm1
Update to 5.20.9-1ubuntu0.1~esm1
libphp-adodb Ubuntu:Pro:20.04:LTS
- Versions
- 5.20.14-1
- 5.20.15-1
- 5.20.16-1
- Affected ranges
- ECOSYSTEM: < 5.20.16-1ubuntu0.1~esm1
Update to 5.20.16-1ubuntu0.1~esm1
libphp-adodb Ubuntu:22.04:LTS
- Versions
- 5.20.19-1
- Affected ranges
- ECOSYSTEM: < 5.20.19-1ubuntu0.1
Update to 5.20.19-1ubuntu0.1