CVE-2021-39171
CVE-2021-39171 · Unlimited transforms allowed for signed nodes
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. Prior to version 3.1.0, a malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack. This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.
CVSS 5.3 · Medium · EPSS 1.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
passport-saml
- Versions
- < 3.1.0: Affected
No fix published
passport-saml npm
- Affected ranges
- SEMVER: < 3.1.0
Update to 3.1.0