CVE-2021-39187
CVE-2021-39187 · Crash server with query parameter
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to version 4.10.3, Parse Server crashes when if a query request contains an invalid value for the `explain` option. This is due to a bug in the MongoDB Node.js driver which throws an exception that Parse Server cannot catch. There is a patch for this issue in version 4.10.3. No workarounds aside from upgrading are known to exist.
CVSS 7.5 · High · EPSS 1.8% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
parse-server
- Versions
- < 4.10.3: Affected
No fix published
parse-server npm
- Affected ranges
- SEMVER: < 4.10.3
Update to 4.10.3
Original sources
- https://github.com/parse-community/parse-server/security/advisories/GHSA-xqp8-w826-hh6x
- https://github.com/parse-community/parse-server/commit/308668c89474223e2448be92d6823b52c1c313ec
- https://github.com/parse-community/parse-server/releases/tag/4.10.3
- https://jira.mongodb.org/browse/NODE-3463
- https://nvd.nist.gov/vuln/detail/CVE-2021-39187