CVE-2021-39212
CVE-2021-39212 · Issue when Configuring the ImageMagick Security Policy
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ImageMagick is free software delivered as a ready-to-run binary distribution or as source code that you may use, copy, modify, and distribute in both open and proprietary applications. In affected versions and in certain cases, Postscript files could be read and written when specifically excluded by a `module` policy in `policy.xml`. ex. <policy domain="module" rights="none" pattern="PS" />. The issue has been resolved in ImageMagick 7.1.0-7 and in 6.9.12-22. Fortunately, in the wild, few users utilize the `module` policy and instead use the `coder` policy that is also our workaround recommendation: <policy domain="coder" rights="none" pattern="{PS,EPI,EPS,EPSF,EPSI}" />.
CVSS 4.4 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
imagemagick
- Versions
- >= 7.0.0, < 7.1.0-7: Affected
- < 6.9.12-22: Affected
No fix published
imagemagick Debian:12
- Affected ranges
- ECOSYSTEM: < 8:6.9.11.60+dfsg-1.5
Update to 8:6.9.11.60+dfsg-1.5
imagemagick Debian:13
- Affected ranges
- ECOSYSTEM: < 8:6.9.11.60+dfsg-1.5
Update to 8:6.9.11.60+dfsg-1.5
imagemagick Debian:14
- Affected ranges
- ECOSYSTEM: < 8:6.9.11.60+dfsg-1.5
Update to 8:6.9.11.60+dfsg-1.5
imagemagick Ubuntu:20.04:LTS
- Versions
- 8:6.9.10.23+dfsg-2.1ubuntu3
- 8:6.9.10.23+dfsg-2.1ubuntu8
- 8:6.9.10.23+dfsg-2.1ubuntu9
- 8:6.9.10.23+dfsg-2.1ubuntu10
- 8:6.9.10.23+dfsg-2.1ubuntu11
- 8:6.9.10.23+dfsg-2.1ubuntu11.1
- 8:6.9.10.23+dfsg-2.1ubuntu11.2
- 8:6.9.10.23+dfsg-2.1ubuntu11.4
- 8:6.9.10.23+dfsg-2.1ubuntu11.5
- 8:6.9.10.23+dfsg-2.1ubuntu11.6
- 8:6.9.10.23+dfsg-2.1ubuntu11.7
- Affected ranges
- ECOSYSTEM: < 8:6.9.10.23+dfsg-2.1ubuntu11.9
Update to 8:6.9.10.23+dfsg-2.1ubuntu11.9
imagemagick Ubuntu:Pro:22.04:LTS
- Versions
- 8:6.9.11.60+dfsg-1ubuntu1
- 8:6.9.11.60+dfsg-1.3
- 8:6.9.11.60+dfsg-1.3build1
- 8:6.9.11.60+dfsg-1.3build2
- 8:6.9.11.60+dfsg-1.3ubuntu0.22.04.1
- Affected ranges
- ECOSYSTEM: < 8:6.9.11.60+dfsg-1.3ubuntu0.22.04.1+esm1
Update to 8:6.9.11.60+dfsg-1.3ubuntu0.22.04.1+esm1
Original sources
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-qvhr-jj4p-j2qr
- https://github.com/ImageMagick/ImageMagick/commit/01faddbe2711a4156180c4a92837e2f23683cc68
- https://github.com/ImageMagick/ImageMagick/commit/35893e7cad78ce461fcaffa56076c11700ba5e4e
- https://lists.debian.org/debian-lts-announce/2023/05/msg00020.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-39212