CVE-2021-3981
CVE-2021-3981
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw in grub2 was found where its configuration file, known as grub.cfg, is being created with the wrong permission set allowing non privileged users to read its content. This represents a low severity confidentiality issue, as those users can eventually read any encrypted passwords present in grub.cfg. This flaw affects grub2 2.06 and previous versions. This issue has been fixed in grub upstream but no version with the fix is currently released.
CVSS 3.3 · Low · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
grub2
- Versions
- grub2 2.06 and previous versions: Affected
No fix published
grub2 Debian:12
- Affected ranges
- ECOSYSTEM: < 2.06-8
Update to 2.06-8
grub2 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.06-8
Update to 2.06-8
grub2 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.06-8
Update to 2.06-8
grub2-signed Ubuntu:Pro:14.04:LTS
- Versions
- 1.22
- 1.23
- 1.24
- 1.25
- 1.26
- 1.27
- 1.30
- 1.31
- 1.32
- 1.33
- 1.34
- 1.34.1
- 1.34.2
- 1.34.3
- 1.34.4
- 1.34.5
- 1.34.6
- 1.34.7
- 1.34.8
- 1.34.9
- 1.34.13
- 1.34.14
- 1.34.16
- 1.34.17
- 1.34.18
- 1.34.20
- 1.34.22
- 1.34.24
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
grub2-signed Ubuntu:16.04:LTS
- Versions
- 1.55
- 1.56
- 1.57
- 1.58
- 1.59
- 1.61
- 1.62
- 1.63
- 1.64
- 1.65
- 1.66
- 1.66.1
- 1.66.2
- 1.66.6
- 1.66.7
- 1.66.8
- 1.66.9
- 1.66.11
- 1.66.12
- 1.66.14
- 1.66.15
- 1.66.16
- 1.66.17
- 1.66.18
- 1.66.19
- 1.66.20
- 1.66.21
- 1.66.22
- 1.66.23
- 1.66.26
- 1.66.27
- 1.66.28
- 1.66.29
- 1.167~16.04.1
- 1.167~16.04.2
- 1.167~16.04.4
- 1.167~16.04.6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
grub2-unsigned Ubuntu:16.04:LTS
- Versions
- 2.04-1ubuntu44
- 2.04-1ubuntu44.1
- 2.04-1ubuntu44.1.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
grub2-signed Ubuntu:18.04:LTS
- Versions
- 1.85
- 1.86
- 1.87
- 1.89
- 1.91
- 1.92
- 1.93
- 1.93.1
- 1.93.2
- 1.93.3
- 1.93.4
- 1.93.5
- 1.93.7
- 1.93.8
- 1.93.10
- 1.93.11
- 1.93.13
- 1.93.14
- 1.93.15
- 1.93.16
- 1.93.18
- 1.93.19
- 1.93.20
- 1.93.21
- 1.93.22
- 1.93.24
- 1.167~18.04.1
- 1.167~18.04.3
- 1.167~18.04.5
- 1.173.2~18.04.1
- 1.187.2~18.04.1
- 1.187.3~18.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
grub2-unsigned Ubuntu:18.04:LTS
- Versions
- 2.04-1ubuntu44
- 2.04-1ubuntu44.1
- 2.04-1ubuntu44.1.2
- 2.04-1ubuntu47.4
- 2.06-2ubuntu14
- 2.06-2ubuntu14.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
grub2-signed Ubuntu:20.04:LTS
- Versions
- 1.128
- 1.129
- 1.130
- 1.131
- 1.133
- 1.134
- 1.135
- 1.136
- 1.137
- 1.138
- 1.139
- 1.140
- 1.141
- 1.142
- 1.142.1
- 1.142.3
- 1.142.4
- 1.142.5
- 1.142.6
- 1.142.8
- 1.142.9
- 1.142.10
- 1.142.11
- 1.167
- 1.167.2
- 1.173.2~20.04.1
- 1.173.4
- 1.187.2~20.04.2
- Affected ranges
- ECOSYSTEM: < 1.187.3~20.04.1
Update to 1.187.3~20.04.1
grub2-unsigned Ubuntu:20.04:LTS
- Versions
- 2.04-1ubuntu44
- 2.04-1ubuntu44.2
- 2.04-1ubuntu47.4
- 2.04-1ubuntu47.5
- 2.06-2ubuntu14
- Affected ranges
- ECOSYSTEM: < 2.06-2ubuntu14.1
Update to 2.06-2ubuntu14.1
grub2-signed Ubuntu:22.04:LTS
- Versions
- 1.173
- 1.174
- 1.176
- 1.177
- 1.178
- 1.179
- 1.180
- 1.182~22.04.1
- 1.187.2
- Affected ranges
- ECOSYSTEM: < 1.187.3~22.04.1
Update to 1.187.3~22.04.1
grub2-unsigned Ubuntu:22.04:LTS
- Versions
- 2.04-1ubuntu47
- 2.04-1ubuntu48
- 2.06-2ubuntu3
- 2.06-2ubuntu4
- 2.06-2ubuntu5
- 2.06-2ubuntu6
- 2.06-2ubuntu7
- 2.06-2ubuntu10
- 2.06-2ubuntu14
- Affected ranges
- ECOSYSTEM: < 2.06-2ubuntu14.1
Update to 2.06-2ubuntu14.1
Original sources
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AI776L35DDYPCSAAJPJM3ZEQYSFZHBJX/
- https://bugzilla.redhat.com/show_bug.cgi?id=2024170
- https://security.gentoo.org/glsa/202209-12
- http://www.openwall.com/lists/oss-security/2024/01/15/3
- https://nvd.nist.gov/vuln/detail/CVE-2021-3981