p PatchFirst

CVE-2021-3988

CVE-2021-3988 · Cross-site Scripting (XSS) in janeczku/calibre-web

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A Cross-site Scripting (XSS) vulnerability exists in janeczku/calibre-web, specifically in the file `edit_books.js`. The vulnerability occurs when editing book properties, such as uploading a cover or a format. The affected code directly inserts user input into the DOM without proper sanitization, allowing attackers to execute arbitrary JavaScript code. This can lead to various attacks, including stealing cookies. The issue is present in the code handling the `#btn-upload-cover` change event.

CVSS 5.7 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • janeczku/calibre-web

    Versions
    • ≥ unspecified, ≤ latest: Affected (custom)

    No fix published

  • calibreweb PyPI

    Versions
    • 0.6.12
    • 0.6.13
    • 0.6.14
    Affected ranges
    • ECOSYSTEM: < 0.6.15

    Update to 0.6.15

Original sources

Check your server →