p PatchFirst

CVE-2021-39880

CVE-2021-39880

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A Denial Of Service vulnerability in the apollo_upload_server Ruby gem in GitLab CE/EE all versions starting from 11.9 before 14.0.9, all versions starting from 14.1 before 14.1.4, and all versions starting from 14.2 before 14.2.2 allows an attacker to deny access to all users via specially crafted requests to the apollo_upload_server middleware.

CVSS 6.5 · Medium · EPSS 2.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • >=14.2, <14.2.2: Affected
    • >=14.1, <14.1.4: Affected
    • >=11.9, <14.0.9: Affected

    No fix published

  • ruby-apollo-upload-server Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.1.0-1

    Update to 2.1.0-1

  • ruby-apollo-upload-server Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.1.0-1

    Update to 2.1.0-1

  • ruby-apollo-upload-server Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.1.0-1

    Update to 2.1.0-1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →