CVE-2021-4010
CVE-2021-4010
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in xorg-x11-server in versions before 21.1.2 and before 1.20.14. An out-of-bounds access can occur in the SProcScreenSaverSuspend function. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
CVSS 7.8 · High · EPSS 0.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
xorg-x11-server
- Versions
- xorg-x11-server 21.1.2, xorg-x11-server 1.20.14: Affected
No fix published
xorg-server Debian:12
- Affected ranges
- ECOSYSTEM: < 2:1.20.13-3
Update to 2:1.20.13-3
xorg-server Debian:13
- Affected ranges
- ECOSYSTEM: < 2:1.20.13-3
Update to 2:1.20.13-3
xorg-server Debian:14
- Affected ranges
- ECOSYSTEM: < 2:1.20.13-3
Update to 2:1.20.13-3
xwayland Debian:12
- Affected ranges
- ECOSYSTEM: < 2:21.1.4-1
Update to 2:21.1.4-1
xwayland Debian:13
- Affected ranges
- ECOSYSTEM: < 2:21.1.4-1
Update to 2:21.1.4-1
xwayland Debian:14
- Affected ranges
- ECOSYSTEM: < 2:21.1.4-1
Update to 2:21.1.4-1
xorg-server-hwe-18.04 Ubuntu:18.04:LTS
- Versions
- 2:1.20.1-3ubuntu2.1~18.04.1
- 2:1.20.4-1ubuntu3~18.04.1
- 2:1.20.5+git20191008-0ubuntu1~18.04.1
- 2:1.20.8-2ubuntu2.1~18.04.1
- 2:1.20.8-2ubuntu2.2~18.04.1
- 2:1.20.8-2ubuntu2.2~18.04.2
- 2:1.20.8-2ubuntu2.2~18.04.3
- 2:1.20.8-2ubuntu2.2~18.04.4
- 2:1.20.8-2ubuntu2.2~18.04.5
- Affected ranges
- ECOSYSTEM: < 2:1.20.8-2ubuntu2.2~18.04.6
Update to 2:1.20.8-2ubuntu2.2~18.04.6
xorg-server Ubuntu:20.04:LTS
- Versions
- 2:1.20.5+git20191008-0ubuntu1
- 2:1.20.6-1ubuntu1
- 2:1.20.7-2ubuntu1
- 2:1.20.7-2ubuntu2
- 2:1.20.8-2ubuntu2
- 2:1.20.8-2ubuntu2.1
- 2:1.20.8-2ubuntu2.2
- 2:1.20.8-2ubuntu2.3
- 2:1.20.8-2ubuntu2.4
- 2:1.20.8-2ubuntu2.6
- 2:1.20.9-2ubuntu1.1~20.04.1
- 2:1.20.9-2ubuntu1.2~20.04.1
- 2:1.20.9-2ubuntu1.2~20.04.2
- 2:1.20.11-1ubuntu1~20.04.2
- Affected ranges
- ECOSYSTEM: < 2:1.20.13-1ubuntu1~20.04.2
Update to 2:1.20.13-1ubuntu1~20.04.2
xorg-server Ubuntu:22.04:LTS
- Versions
- 2:1.20.13-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 2:1.20.13-1ubuntu2
Update to 2:1.20.13-1ubuntu2
xwayland Ubuntu:22.04:LTS
- Versions
- 2:21.1.2-0ubuntu1
- 2:21.1.3-1
- Affected ranges
- ECOSYSTEM: < 2:21.1.3-1ubuntu1
Update to 2:21.1.3-1ubuntu1
Original sources
- https://lists.x.org/archives/xorg-announce/2021-December/003122.html
- https://lists.x.org/archives/xorg-announce/2021-December/003124.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PDHYZM6FII35JA7J275MFCJO6ADJUPQX/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/T57DCF726O5LLTST4NBL5PQ7DLPB46HT/
- https://www.zerodayinitiative.com/advisories/ZDI-21-1549/
- https://www.debian.org/security/2021/dsa-5027
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NKLSZCY47QK4RCJFXITYFALCGPJAFXOK/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NXTRPFEQLFZ6NT2LPLZEID664RGC3OCC/
- https://security.netapp.com/advisory/ntap-20220114-0004/
- https://security.gentoo.org/glsa/202305-30
- https://nvd.nist.gov/vuln/detail/CVE-2021-4010