p PatchFirst

CVE-2021-41079

CVE-2021-41079 · Apache Tomcat DoS with unexpected TLS packet

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Apache Tomcat 8.5.0 to 8.5.63, 9.0.0-M1 to 9.0.43 and 10.0.0-M1 to 10.0.2 did not properly validate incoming TLS packets. When Tomcat was configured to use NIO+OpenSSL or NIO2+OpenSSL for TLS, a specially crafted packet could be used to trigger an infinite loop resulting in a denial of service.

CVSS 7.5 · High · EPSS 7.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache tomcat

    Versions
    • Apache Tomcat 8.5 8.5.0 to 8.5.63: Affected
    • Apache Tomcat 9 9.0.0-M1 to 9.0.43: Affected
    • Apache Tomcat 10 10.0.0-M1 to 10.0.2: Affected

    No fix published

  • tomcat9 Debian:12

    Affected ranges
    • ECOSYSTEM: < 9.0.53-1

    Update to 9.0.53-1

  • tomcat9 Debian:13

    Affected ranges
    • ECOSYSTEM: < 9.0.53-1

    Update to 9.0.53-1

  • tomcat9 Debian:14

    Affected ranges
    • ECOSYSTEM: < 9.0.53-1

    Update to 9.0.53-1

  • tomcat9 Ubuntu:18.04:LTS

    Versions
    • 9.0.16-3~18.04.1
    • 9.0.16-3ubuntu0.18.04.1
    Affected ranges
    • ECOSYSTEM: < 9.0.16-3ubuntu0.18.04.2

    Update to 9.0.16-3ubuntu0.18.04.2

  • tomcat8 Ubuntu:Pro:18.04:LTS

    Versions
    • 8.5.21-1ubuntu1
    • 8.5.29-1
    • 8.5.30-1
    • 8.5.30-1ubuntu1
    • 8.5.30-1ubuntu1.2
    • 8.5.30-1ubuntu1.3
    • 8.5.30-1ubuntu1.4
    • 8.5.39-1ubuntu1~18.04.1
    • 8.5.39-1ubuntu1~18.04.2
    • 8.5.39-1ubuntu1~18.04.3
    • 8.5.39-1ubuntu1~18.04.3+esm1
    Affected ranges
    • ECOSYSTEM: < 8.5.39-1ubuntu1~18.04.3+esm2

    Update to 8.5.39-1ubuntu1~18.04.3+esm2

  • tomcat9 Ubuntu:20.04:LTS

    Versions
    • 9.0.24-1
    • 9.0.27-1
    • 9.0.31-1
    • 9.0.31-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 9.0.31-1ubuntu0.2

    Update to 9.0.31-1ubuntu0.2

Original sources

Check your server →