CVE-2021-41122
CVE-2021-41122 · Bounds check missing for decimal args in Vyper
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions external functions did not properly validate the bounds of decimal arguments. The can lead to logic errors. This issue has been resolved in version 0.3.0.
CVSS 4.3 · Medium · EPSS 0.8% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
vyper
- Versions
- < 0.3.0: Affected
No fix published
vyper PyPI
- Versions
- 0.1.0b1
- 0.1.0b10
- 0.1.0b11
- 0.1.0b12
- 0.1.0b13
- 0.1.0b14
- 0.1.0b15
- 0.1.0b16
- 0.1.0b17
- 0.1.0b2
- 0.1.0b3
- 0.1.0b4
- 0.1.0b5
- 0.1.0b6
- 0.1.0b7
- 0.1.0b8
- 0.1.0b9
- 0.2.1
- 0.2.10
- 0.2.11
- 0.2.12
- 0.2.13
- 0.2.14
- 0.2.15
- 0.2.16
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.2.7
- 0.2.8
- 0.2.9
- Affected ranges
- ECOSYSTEM: < 0.3.0
Update to 0.3.0