CVE-2021-41131
CVE-2021-41131 · Client metadata path-traversal in python-tuf
This page contains facts from public vulnerability sources. Check the original advisory before updating.
python-tuf is a Python reference implementation of The Update Framework (TUF). In both clients (`tuf/client` and `tuf/ngclient`), there is a path traversal vulnerability that in the worst case can overwrite files ending in `.json` anywhere on the client system on a call to `get_one_valid_targetinfo()`. It occurs because the rolename is used to form the filename, and may contain path traversal characters (ie `../../name.json`). The impact is mitigated by a few facts: It only affects implementations that allow arbitrary rolename selection for delegated targets metadata, The attack requires the ability to A) insert new metadata for the path-traversing role and B) get the role delegated by an existing targets metadata, The written file content is heavily restricted since it needs to be a valid, signed targets file. The file extension is always .json. A fix is available in version 0.19 or newer. There are no workarounds that do not require code changes. Clients can restrict the allowed character set for rolenames, or they can store metadata in files named in a way that is not vulnerable: neither of these approaches is possible without modifying python-tuf.
CVSS 7.5 · High · EPSS 1.5% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
python-tuf
- Versions
- < 0.19.0: Affected
No fix published
tuf PyPI
- Versions
- 0.10.0
- 0.10.1
- 0.10.2
- 0.11.0
- 0.11.1
- 0.11.2.dev1
- 0.11.2.dev2
- 0.11.2.dev3
- 0.11.dev0
- 0.12.0
- 0.12.1
- 0.12.2
- 0.12.dev0
- 0.12.dev1
- 0.12.dev2
- 0.13.0
- 0.14.0
- 0.15.0
- 0.16.0
- 0.17.0
- 0.18.0
- 0.18.1
- 0.7.5
- 0.9.8
- 0.9.9
- Affected ranges
- ECOSYSTEM: < 0.19.0
Update to 0.19.0
tuf PyPI
- Versions
- 0.10.0
- 0.10.1
- 0.10.2
- 0.11.0
- 0.11.1
- 0.11.2.dev1
- 0.11.2.dev2
- 0.11.2.dev3
- 0.11.dev0
- 0.12.0
- 0.12.1
- 0.12.2
- 0.12.dev0
- 0.12.dev1
- 0.12.dev2
- 0.13.0
- 0.14.0
- 0.15.0
- 0.16.0
- 0.17.0
- 0.18.0
- 0.18.1
- 0.7.5
- 0.9.8
- 0.9.9
- Affected ranges
- GIT: < 4ad7ae48fda594b640139c3b7eae21ed5155a102
- ECOSYSTEM: < 0.19.0
Update to 0.19.0