p PatchFirst

CVE-2021-41211

CVE-2021-41211 · Heap OOB read in shape inference for `QuantizeV2`

This page contains facts from public vulnerability sources. Check the original advisory before updating.

TensorFlow is an open source platform for machine learning. In affected versions the shape inference code for `QuantizeV2` can trigger a read outside of bounds of heap allocated array. This occurs whenever `axis` is a negative value less than `-1`. In this case, we are accessing data before the start of a heap buffer. The code allows `axis` to be an optional argument (`s` would contain an `error::NOT_FOUND` error code). Otherwise, it assumes that `axis` is a valid index into the dimensions of the `input` tensor. If `axis` is less than `-1` then this results in a heap OOB read. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, as this version is the only one that is also affected.

CVSS 7.1 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • tensorflow

    Versions
    • >= 2.6.0, < 2.6.1: Affected

    No fix published

  • tensorflow PyPI

    Versions
    • 2.6.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.6.0, < 2.6.1

    Update to 2.6.1

  • tensorflow-cpu PyPI

    Versions
    • 2.6.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.6.0, < 2.6.1

    Update to 2.6.1

  • tensorflow-gpu PyPI

    Versions
    • 2.6.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.6.0, < 2.6.1

    Update to 2.6.1

  • tensorflow PyPI

    Versions
    • 2.6.0
    • 2.7.0rc0
    • 2.7.0rc1
    Affected ranges
    • GIT: < a0d64445116c43cf46a5666bd4eee28e7a82f244
    • ECOSYSTEM: ≥ 2.6.0, < 2.6.1 ∪ ≥ 2.7.0rc0, < 2.7.0

    Update to 2.6.1; Update to 2.7.0

  • tensorflow-cpu PyPI

    Versions
    • 2.6.0
    • 2.7.0rc0
    • 2.7.0rc1
    Affected ranges
    • GIT: < a0d64445116c43cf46a5666bd4eee28e7a82f244
    • ECOSYSTEM: ≥ 2.6.0, < 2.6.1 ∪ ≥ 2.7.0rc0, < 2.7.0

    Update to 2.6.1; Update to 2.7.0

  • tensorflow-gpu PyPI

    Versions
    • 2.6.0
    • 2.7.0rc0
    • 2.7.0rc1
    Affected ranges
    • GIT: < a0d64445116c43cf46a5666bd4eee28e7a82f244
    • ECOSYSTEM: ≥ 2.6.0, < 2.6.1 ∪ ≥ 2.7.0rc0, < 2.7.0

    Update to 2.6.1; Update to 2.7.0

Original sources

Check your server →