p PatchFirst

CVE-2021-41258

CVE-2021-41258 · Cross-site scripting (XSS) from image block content in the site frontend

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Kirby is an open source file structured CMS. In affected versions Kirby's blocks field stores structured data for each block. This data is then used in block snippets to convert the blocks to HTML for use in your templates. We recommend to escape HTML special characters to protect against cross-site scripting (XSS) attacks. The default snippet for the image block unfortunately did not use our escaping helper. This made it possible to include malicious HTML code in the source, alt and link fields of the image block, which would then be displayed on the site frontend and executed in the browsers of site visitors and logged in users who are browsing the site. Attackers must be in your group of authenticated Panel users in order to exploit this weakness. Users who do not make use of the blocks field are not affected. This issue has been patched in Kirby version 3.5.8 by escaping special HTML characters in the output from the default image block snippet. Please update to this or a later version to fix the vulnerability.

CVSS 7.3 · High · EPSS 0.8% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • kirby

    Versions
    • >= 3.5.0, < 3.5.8: Affected

    No fix published

  • getkirby/cms Packagist

    Versions
    • 3.5.0
    • 3.5.1
    • 3.5.1-rc.1
    • 3.5.2
    • 3.5.2-rc.1
    • 3.5.3
    • 3.5.3.1
    • 3.5.4
    • 3.5.5
    • 3.5.5-rc.1
    • 3.5.6
    • 3.5.6-rc.1
    • 3.5.7
    • 3.5.7-rc.1
    • 3.5.7.1
    Affected ranges
    • ECOSYSTEM: ≥ 3.5.0, < 3.5.8

    Update to 3.5.8

Original sources

Check your server →