CVE-2021-41264
CVE-2021-41264 · UUPSUpgradeable vulnerability in OpenZeppelin Contracts
This page contains facts from public vulnerability sources. Check the original advisory before updating.
OpenZeppelin Contracts is a library for smart contract development. In affected versions upgradeable contracts using `UUPSUpgradeable` may be vulnerable to an attack affecting uninitialized implementation contracts. A fix is included in version 4.3.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`. For users unable to upgrade; initialize implementation contracts using `UUPSUpgradeable` by invoking the initializer function (usually called `initialize`). An example is provided [in the forum](https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301).
CVSS 9.8 · Critical · EPSS 1.5% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
openzeppelin-contracts
- Versions
- >= 4.1.0 < 4.3.2: Affected
No fix published
@openzeppelin/contracts npm
- Affected ranges
- SEMVER: ≥ 4.1.0, < 4.3.2
Update to 4.3.2
@openzeppelin/contracts-upgradeable npm
- Affected ranges
- SEMVER: ≥ 4.1.0, < 4.3.2
Update to 4.3.2
Original sources
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-5vp3-v4hc-gx76
- https://github.com/OpenZeppelin/openzeppelin-contracts/commit/024cc50df478d2e8f78539819749e94d6df60592
- https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301
- https://nvd.nist.gov/vuln/detail/CVE-2021-41264