CVE-2021-43560
CVE-2021-43560
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. Insufficient capability checks made it possible to fetch other users' calendar action events.
CVSS 5.3 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- moodle 3.11.4, moodle 3.10.8 and moodle 3.9.11: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.9.0
- v3.9.0-beta
- v3.9.0-rc1
- v3.9.0-rc2
- v3.9.0-rc3
- v3.9.1
- v3.9.10
- v3.9.2
- v3.9.3
- v3.9.4
- v3.9.5
- v3.9.6
- v3.9.7
- v3.9.8
- v3.9.9
- Affected ranges
- ECOSYSTEM: ≥ 3.9, < 3.9.11
Update to 3.9.11
moodle/moodle Packagist
- Versions
- v3.10.0
- v3.10.0-beta
- v3.10.0-rc1
- v3.10.0-rc2
- v3.10.1
- v3.10.2
- v3.10.3
- v3.10.4
- v3.10.5
- v3.10.6
- v3.10.7
- Affected ranges
- ECOSYSTEM: ≥ 3.10, < 3.10.8
Update to 3.10.8
moodle/moodle Packagist
- Versions
- v3.11.0
- v3.11.0-beta
- v3.11.0-rc1
- v3.11.0-rc2
- v3.11.1
- v3.11.2
- v3.11.3
- Affected ranges
- ECOSYSTEM: ≥ 3.11, < 3.11.4
Update to 3.11.4
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published