CVE-2021-43776
CVE-2021-43776 · XSS vulnerability in @backstage/plugin-auth-backend
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Backstage is an open platform for building developer portals. In affected versions the auth-backend plugin allows a malicious actor to trick another user into visiting a vulnerable URL that executes an XSS attack. This attack can potentially allow the attacker to exfiltrate access tokens or other secrets from the user's browser. The default CSP does prevent this attack, but it is expected that some deployments have these policies disabled due to incompatibilities. This is vulnerability is patched in version `0.4.9` of `@backstage/plugin-auth-backend`.
CVSS 7.4 · High · EPSS 0.7% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
backstage
- Versions
- < 0.4.9: Affected
No fix published
@backstage/plugin-auth-backend npm
- Affected ranges
- SEMVER: < 0.4.9
Update to 0.4.9