CVE-2021-43789
CVE-2021-43789 · Blind SQLi using Search filters in PrestaShop
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PrestaShop is an Open Source e-commerce web application. Versions of PrestaShop prior to 1.7.8.2 are vulnerable to blind SQL injection using search filters with `orderBy` and `sortOrder` parameters. The problem is fixed in version 1.7.8.2.
CVSS 7.5 · High · EPSS 4.7% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
prestashop
- Versions
- >= 1.7.5.0, <= 1.7.8.1: Affected
No fix published
prestashop/prestashop Packagist
- Versions
- 1.7.5.0
- 1.7.5.1
- 1.7.5.2
- 1.7.6.0
- 1.7.6.0-beta.1
- 1.7.6.0-rc.1
- 1.7.6.0-rc.2
- 1.7.6.1
- 1.7.6.2
- 1.7.6.3
- 1.7.6.4
- 1.7.6.5
- 1.7.6.6
- 1.7.6.7
- 1.7.6.8
- 1.7.6.9
- 1.7.7.0
- 1.7.7.0-beta.1
- 1.7.7.0-beta.2
- 1.7.7.0-rc.1
- 1.7.7.1
- 1.7.7.2
- 1.7.7.3
- 1.7.7.4
- 1.7.7.5
- 1.7.7.6
- 1.7.7.7
- 1.7.7.8
- 1.7.8.0
- 1.7.8.0-beta.1
- 1.7.8.0-rc.1
- 1.7.8.1
- Affected ranges
- ECOSYSTEM: ≥ 1.7.5.0, < 1.7.8.2
Update to 1.7.8.2