p PatchFirst

CVE-2021-43803

CVE-2021-43803 · Unexpected server crash in Next.js

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Next.js is a React framework. In versions of Next.js prior to 12.0.5 or 11.1.3, invalid or malformed URLs could lead to a server crash. In order to be affected by this issue, the deployment must use Next.js versions above 11.1.0 and below 12.0.5, Node.js above 15.0.0, and next start or a custom server. Deployments on Vercel are not affected, along with similar environments where invalid requests are filtered before reaching Next.js. Versions 12.0.5 and 11.1.3 contain patches for this issue.

CVSS 7.5 · High · EPSS 47.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • next.js

    Versions
    • >= 11.1.0, < 11.1.3: Affected
    • >= 12.0.0, < 12.0.5: Affected

    No fix published

  • next npm

    Affected ranges
    • SEMVER: ≥ 12.0.0, < 12.0.5

    Update to 12.0.5

  • next npm

    Affected ranges
    • SEMVER: ≥ 0.9.9, < 11.1.3

    Update to 11.1.3

Original sources

Check your server →