p PatchFirst

CVE-2021-43854

CVE-2021-43854 · Inefficient Regular Expression Complexity in nltk

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NLTK (Natural Language Toolkit) is a suite of open source Python modules, data sets, and tutorials supporting research and development in Natural Language Processing. Versions prior to 3.6.5 are vulnerable to regular expression denial of service (ReDoS) attacks. The vulnerability is present in PunktSentenceTokenizer, sent_tokenize and word_tokenize. Any users of this class, or these two functions, are vulnerable to the ReDoS attack. In short, a specifically crafted long input to any of these vulnerable functions will cause them to take a significant amount of execution time. If your program relies on any of the vulnerable functions for tokenizing unpredictable user input, then we would strongly recommend upgrading to a version of NLTK without the vulnerability. For users unable to upgrade the execution time can be bounded by limiting the maximum length of an input to any of the vulnerable functions. Our recommendation is to implement such a limit.

CVSS 7.5 · High · EPSS 2.8% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • nltk

    Versions
    • < 3.6.5: Affected

    No fix published

  • nltk Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.6.7-1

    Update to 3.6.7-1

  • nltk Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.6.7-1

    Update to 3.6.7-1

  • nltk Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.6.7-1

    Update to 3.6.7-1

  • nltk PyPI

    Versions
    • 0.8
    • 0.9
    • 0.9.3
    • 0.9.4
    • 0.9.5
    • 0.9.6
    • 0.9.7
    • 0.9.8
    • 0.9.9
    • 2.0.1
    • 2.0.1rc1
    • 2.0.1rc2-git
    • 2.0.1rc3
    • 2.0.1rc4
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.0.5
    • 2.0b4
    • 2.0b5
    • 2.0b6
    • 2.0b7
    • 2.0b8
    • 2.0b9
    • 3.0.0
    • 3.0.0b1
    • 3.0.0b2
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.0.5
    • 3.1
    • 3.2
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2.4
    • 3.2.5
    • 3.3
    • 3.4
    • 3.4.1
    • 3.4.2
    • 3.4.3
    • 3.4.4
    • 3.4.5
    • 3.5
    • 3.5b1
    • 3.6
    • 3.6.1
    • 3.6.2
    • 3.6.3
    • 3.6.4
    • 3.6.5
    Affected ranges
    • ECOSYSTEM: < 3.6.6

    Update to 3.6.6

  • nltk PyPI

    Versions
    • 0.8
    • 0.9
    • 0.9.3
    • 0.9.4
    • 0.9.5
    • 0.9.6
    • 0.9.7
    • 0.9.8
    • 0.9.9
    • 2.0.1
    • 2.0.1rc1
    • 2.0.1rc2-git
    • 2.0.1rc3
    • 2.0.1rc4
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.0.5
    • 2.0b4
    • 2.0b5
    • 2.0b6
    • 2.0b7
    • 2.0b8
    • 2.0b9
    • 3.0.0
    • 3.0.0b1
    • 3.0.0b2
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.0.5
    • 3.1
    • 3.2
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2.4
    • 3.2.5
    • 3.3
    • 3.4
    • 3.4.1
    • 3.4.2
    • 3.4.3
    • 3.4.4
    • 3.4.5
    • 3.5
    • 3.5b1
    • 3.6
    • 3.6.1
    • 3.6.2
    • 3.6.3
    • 3.6.4
    Affected ranges
    • GIT: < 1405aad979c6b8080dbbc8e0858f89b2e3690341
    • ECOSYSTEM: < 3.6.5

    Update to 3.6.5

  • nltk Ubuntu:Pro:14.04:LTS

    Versions
    • 2.0~b9-0ubuntu4
    • 2.0~b9-0ubuntu4.1~esm2
    Affected ranges
    • ECOSYSTEM: < 2.0~b9-0ubuntu4.1~esm4

    Update to 2.0~b9-0ubuntu4.1~esm4

  • nltk Ubuntu:Pro:16.04:LTS

    Versions
    • 3.0.4-1
    • 3.0.5-1
    • 3.1-1
    • 3.1-1ubuntu0.1
    • 3.1-1ubuntu0.1+esm1
    Affected ranges
    • ECOSYSTEM: < 3.1-1ubuntu0.1+esm2

    Update to 3.1-1ubuntu0.1+esm2

  • nltk Ubuntu:Pro:18.04:LTS

    Versions
    • 3.2.4-1
    • 3.2.5-1
    • 3.2.5-1ubuntu0.1
    • 3.2.5-1ubuntu0.1+esm1
    Affected ranges
    • ECOSYSTEM: < 3.2.5-1ubuntu0.1+esm2

    Update to 3.2.5-1ubuntu0.1+esm2

  • nltk Ubuntu:Pro:20.04:LTS

    Versions
    • 3.4.5-1
    • 3.4.5-2
    • 3.4.5-2ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: < 3.4.5-2ubuntu0.1~esm2

    Update to 3.4.5-2ubuntu0.1~esm2

Original sources

Check your server →