p PatchFirst

CVE-2021-44217

CVE-2021-44217

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In Ericsson CodeChecker through 6.18.0, a Stored Cross-site scripting (XSS) vulnerability in the comments component of the reports viewer allows remote attackers to inject arbitrary web script or HTML via the POST JSON data of the /CodeCheckerService API.

CVSS 6.1 · Medium · EPSS 1.6% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • codechecker PyPI

    Versions
    • 6.16.0
    • 6.16.0a1
    • 6.17.0
    • 6.18.0
    • 6.18.1
    Affected ranges
    • ECOSYSTEM: < 6.18.2

    Update to 6.18.2

  • codechecker-api PyPI

    No fix published

Original sources

Check your server →