CVE-2021-44420
CVE-2021-44420
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Django 2.2 before 2.2.25, 3.1 before 3.1.14, and 3.2 before 3.2.10, HTTP requests for URLs with trailing newlines could bypass upstream access control based on URL paths.
CVSS 7.3 · High · EPSS 2.4% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
python-django Debian:12
- Affected ranges
- ECOSYSTEM: < 2:3.2.10-1
Update to 2:3.2.10-1
python-django Debian:13
- Affected ranges
- ECOSYSTEM: < 2:3.2.10-1
Update to 2:3.2.10-1
python-django Debian:14
- Affected ranges
- ECOSYSTEM: < 2:3.2.10-1
Update to 2:3.2.10-1
django PyPI
- Versions
- 2.2
- 2.2.1
- 2.2.10
- 2.2.11
- 2.2.12
- 2.2.13
- 2.2.14
- 2.2.15
- 2.2.16
- 2.2.17
- 2.2.18
- 2.2.19
- 2.2.2
- 2.2.20
- 2.2.21
- 2.2.22
- 2.2.23
- 2.2.24
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- 2.2a1
- 2.2b1
- 2.2rc1
- Affected ranges
- ECOSYSTEM: ≥ 2.2a1, < 2.2.25
Update to 2.2.25
django PyPI
- Versions
- 3.0
- 3.0.1
- 3.0.10
- 3.0.11
- 3.0.12
- 3.0.13
- 3.0.14
- 3.0.2
- 3.0.3
- 3.0.4
- 3.0.5
- 3.0.6
- 3.0.7
- 3.0.8
- 3.0.9
- 3.0a1
- 3.0b1
- 3.0rc1
- 3.1
- 3.1.1
- 3.1.10
- 3.1.11
- 3.1.12
- 3.1.13
- 3.1.2
- 3.1.3
- 3.1.4
- 3.1.5
- 3.1.6
- 3.1.7
- 3.1.8
- 3.1.9
- 3.1a1
- 3.1b1
- 3.1rc1
- Affected ranges
- ECOSYSTEM: ≥ 3.0a1, < 3.1.14
Update to 3.1.14
django PyPI
- Versions
- 3.2
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- 3.2.7
- 3.2.8
- 3.2.9
- 3.2a1
- 3.2b1
- 3.2rc1
- Affected ranges
- ECOSYSTEM: ≥ 3.2a1, < 3.2.10
Update to 3.2.10
django PyPI
- Versions
- 2.2
- 2.2.1
- 2.2.10
- 2.2.11
- 2.2.12
- 2.2.13
- 2.2.14
- 2.2.15
- 2.2.16
- 2.2.17
- 2.2.18
- 2.2.19
- 2.2.2
- 2.2.20
- 2.2.21
- 2.2.22
- 2.2.23
- 2.2.24
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- 3.1
- 3.1.1
- 3.1.10
- 3.1.11
- 3.1.12
- 3.1.13
- 3.1.2
- 3.1.3
- 3.1.4
- 3.1.5
- 3.1.6
- 3.1.7
- 3.1.8
- 3.1.9
- 3.2
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- 3.2.7
- 3.2.8
- 3.2.9
- Affected ranges
- ECOSYSTEM: ≥ 2.2, < 2.2.25 ∪ ≥ 3.1, < 3.1.14 ∪ ≥ 3.2, < 3.2.10
Update to 2.2.25; Update to 3.1.14; Update to 3.2.10
python-django Ubuntu:20.04:LTS
- Versions
- 1:1.11.22-1ubuntu1
- 2:2.2.6-1ubuntu1
- 2:2.2.9-2ubuntu1
- 2:2.2.10-1
- 2:2.2.10-1ubuntu1
- 2:2.2.11-1
- 2:2.2.12-1
- 2:2.2.12-1ubuntu0.1
- 2:2.2.12-1ubuntu0.2
- 2:2.2.12-1ubuntu0.3
- 2:2.2.12-1ubuntu0.4
- 2:2.2.12-1ubuntu0.5
- 2:2.2.12-1ubuntu0.6
- 2:2.2.12-1ubuntu0.7
- Affected ranges
- ECOSYSTEM: < 2:2.2.12-1ubuntu0.8
Update to 2:2.2.12-1ubuntu0.8
Original sources
- https://groups.google.com/forum/#%21forum/django-announce
- https://docs.djangoproject.com/en/3.2/releases/security/
- https://www.openwall.com/lists/oss-security/2021/12/07/1
- https://www.djangoproject.com/weblog/2021/dec/07/security-releases/
- https://security.netapp.com/advisory/ntap-20211229-0006/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/B4SQG2EAF4WCI2SLRL6XRDJ3RPK3ZRDV/
- https://nvd.nist.gov/vuln/detail/CVE-2021-44420