p PatchFirst

CVE-2021-44648

CVE-2021-44648

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GNOME gdk-pixbuf 2.42.6 is vulnerable to a heap-buffer overflow vulnerability when decoding the lzw compressed stream of image data in GIF files with lzw minimum code size equals to 12.

CVSS 8.8 · High · EPSS 1.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gdk-pixbuf Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.42.9+dfsg-1

    Update to 2.42.9+dfsg-1

  • gdk-pixbuf Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.42.9+dfsg-1

    Update to 2.42.9+dfsg-1

  • gdk-pixbuf Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.42.9+dfsg-1

    Update to 2.42.9+dfsg-1

  • gdk-pixbuf Ubuntu:20.04:LTS

    Versions
    • 2.40.0+dfsg-1build1
    • 2.40.0+dfsg-1ubuntu1
    • 2.40.0+dfsg-2
    • 2.40.0+dfsg-3
    • 2.40.0+dfsg-3ubuntu0.1
    • 2.40.0+dfsg-3ubuntu0.2
    • 2.40.0+dfsg-3ubuntu0.3
    Affected ranges
    • ECOSYSTEM: < 2.40.0+dfsg-3ubuntu0.4

    Update to 2.40.0+dfsg-3ubuntu0.4

  • gdk-pixbuf Ubuntu:22.04:LTS

    Versions
    • 2.42.6+dfsg-1build2
    • 2.42.6+dfsg-1build3
    • 2.42.6+dfsg-2ubuntu2
    • 2.42.6+dfsg-2ubuntu3
    • 2.42.8+dfsg-1
    Affected ranges
    • ECOSYSTEM: < 2.42.8+dfsg-1ubuntu0.1

    Update to 2.42.8+dfsg-1ubuntu0.1

Original sources

Check your server →