CVE-2021-45417
CVE-2021-45417
This page contains facts from public vulnerability sources. Check the original advisory before updating.
AIDE before 0.17.4 allows local users to obtain root privileges via crafted file metadata (such as XFS extended attributes or tmpfs ACLs), because of a heap-based buffer overflow.
CVSS 7.8 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
aide Debian:12
- Affected ranges
- ECOSYSTEM: < 0.17.4-1
Update to 0.17.4-1
aide Debian:13
- Affected ranges
- ECOSYSTEM: < 0.17.4-1
Update to 0.17.4-1
aide Debian:14
- Affected ranges
- ECOSYSTEM: < 0.17.4-1
Update to 0.17.4-1
aide Ubuntu:Pro:14.04:LTS
- Versions
- 0.15.1-8ubuntu2
- 0.16~a2.git20130520-2
- 0.16~a2.git20130520-2ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 0.16~a2.git20130520-2ubuntu0.1+esm1
Update to 0.16~a2.git20130520-2ubuntu0.1+esm1
aide Ubuntu:Pro:16.04:LTS
- Versions
- 0.16~a2.git20130520-3
- Affected ranges
- ECOSYSTEM: < 0.16~a2.git20130520-3ubuntu0.1~esm1
Update to 0.16~a2.git20130520-3ubuntu0.1~esm1
aide Ubuntu:18.04:LTS
- Versions
- 0.16-1
- 0.16-2
- 0.16-3
- Affected ranges
- ECOSYSTEM: < 0.16-3ubuntu0.1
Update to 0.16-3ubuntu0.1
aide Ubuntu:20.04:LTS
- Versions
- 0.16.1-1build2
- Affected ranges
- ECOSYSTEM: < 0.16.1-1ubuntu0.1
Update to 0.16.1-1ubuntu0.1
Original sources
- https://www.openwall.com/lists/oss-security/2022/01/20/3
- http://www.openwall.com/lists/oss-security/2022/01/20/3
- https://www.debian.org/security/2022/dsa-5051
- https://lists.debian.org/debian-lts-announce/2022/01/msg00024.html
- https://www.ipi.fi/pipermail/aide/2022-January/001713.html
- https://security.gentoo.org/glsa/202311-07
- https://nvd.nist.gov/vuln/detail/CVE-2021-45417