CVE-2021-46023
CVE-2021-46023
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An Untrusted Pointer Dereference was discovered in function mrb_vm_exec in mruby before 3.1.0-rc. The vulnerability causes a segmentation fault and application crash.
CVSS 7.5 · High · EPSS 0.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
mruby Debian:12
- Affected ranges
- ECOSYSTEM: < 3.1.0-1
Update to 3.1.0-1
mruby Debian:13
- Affected ranges
- ECOSYSTEM: < 3.1.0-1
Update to 3.1.0-1
mruby Debian:14
- Affected ranges
- ECOSYSTEM: < 3.1.0-1
Update to 3.1.0-1
mruby Ubuntu:16.04:LTS
- Versions
- 1.1.0+20150817+gita1731254-1
- 1.1.0+20150906+git1cbbb7e1-1
- 1.2.0+20160315+git4f20d58a-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mruby Ubuntu:18.04:LTS
- Versions
- 1.3.0-1
- 1.3.0+20170925+git38185028-1
- 1.3.0+20171029+git77edafb0-1
- 1.4.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mruby Ubuntu:20.04:LTS
- Versions
- 2.0.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mruby Ubuntu:22.04:LTS
- Versions
- 2.1.2-3
- 3.0.0-1
- 3.0.0-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mruby Ubuntu:24.04:LTS
- Versions
- 3.2.0-1
- 3.2.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mruby Ubuntu:25.10
- Versions
- 3.3.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mruby Ubuntu:26.10
- Versions
- 3.4.0-2
- 3.4.0-3
- 4.0.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mruby Ubuntu:26.04:LTS
- Versions
- 3.3.0-1
- 3.4.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published