CVE-2021-47986
CVE-2021-47986 · Parse Server - Unreviewed Code Execution via Malicious Version Tags
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Parse Server before 4.10.0 contains a supply chain vulnerability where incorrect version tags were pushed to the repository linking to unreviewed code in a personal fork. Attackers could exploit this by specifying affected version tags in dependency declarations to execute unreviewed and potentially malicious code.
CVSS 7.7 · High · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
parse-server
- Versions
- ≥ 0, < 4.10.0: Affected (semver)
- 4.10.0: Not affected (semver)
Update to 4.10.0
parse-server npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.5.2
Update to 4.5.2
parse-server npm
- Affected ranges
- SEMVER: ≥ 4.6.0, < 4.10.0
Update to 4.10.0