CVE-2022-0204
CVE-2022-0204
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A heap overflow vulnerability was found in bluez in versions prior to 5.63. An attacker with local network access could pass specially crafted files causing an application to halt or crash, leading to a denial of service.
CVSS 8.8 · High · EPSS 1.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
bluez
- Versions
- bluez versions prior to 5.63: Affected
No fix published
bluez Debian:12
- Affected ranges
- ECOSYSTEM: < 5.64-1
Update to 5.64-1
bluez Debian:13
- Affected ranges
- ECOSYSTEM: < 5.64-1
Update to 5.64-1
bluez Debian:14
- Affected ranges
- ECOSYSTEM: < 5.64-1
Update to 5.64-1
bluez Ubuntu:Pro:16.04:LTS
- Versions
- 5.35-0ubuntu2
- 5.36-0ubuntu1
- 5.37-0ubuntu5
- 5.37-0ubuntu5.1
- 5.37-0ubuntu5.3
- 5.37-0ubuntu5.3+esm1
- Affected ranges
- ECOSYSTEM: < 5.37-0ubuntu5.3+esm2
Update to 5.37-0ubuntu5.3+esm2
bluez Ubuntu:18.04:LTS
- Versions
- 5.46-0ubuntu3
- 5.46-0ubuntu4
- 5.48-0ubuntu3
- 5.48-0ubuntu3.1
- 5.48-0ubuntu3.2
- 5.48-0ubuntu3.3
- 5.48-0ubuntu3.4
- 5.48-0ubuntu3.5
- 5.48-0ubuntu3.6
- 5.48-0ubuntu3.7
- Affected ranges
- ECOSYSTEM: < 5.48-0ubuntu3.8
Update to 5.48-0ubuntu3.8
bluez Ubuntu:20.04:LTS
- Versions
- 5.50-0ubuntu4
- 5.51-0ubuntu1
- 5.51-0ubuntu2
- 5.52-0ubuntu1
- 5.52-0ubuntu2
- 5.53-0ubuntu1
- 5.53-0ubuntu2
- 5.53-0ubuntu3
- 5.53-0ubuntu3.1
- 5.53-0ubuntu3.2
- 5.53-0ubuntu3.3
- 5.53-0ubuntu3.4
- Affected ranges
- ECOSYSTEM: < 5.53-0ubuntu3.5
Update to 5.53-0ubuntu3.5
bluez Ubuntu:22.04:LTS
- Versions
- 5.60-0ubuntu2
- 5.62-0ubuntu1
- 5.62-0ubuntu2
- Affected ranges
- ECOSYSTEM: < 5.63-0ubuntu1
Update to 5.63-0ubuntu1
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=2039807
- https://github.com/bluez/bluez/security/advisories/GHSA-479m-xcq5-9g2q
- https://github.com/bluez/bluez/commit/591c546c536b42bef696d027f64aa22434f8c3f0
- https://security.gentoo.org/glsa/202209-16
- https://lists.debian.org/debian-lts-announce/2022/10/msg00026.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00022.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-0204