CVE-2022-0227
CVE-2022-0227 · Business Logic Errors in SilverStripe Framework
This page contains facts from public vulnerability sources. Check the original advisory before updating.
SilverStripe Framework prior to version 4.10.1 is vulnerable to business logic errors.
CVSS 4.3 · Medium · Fix available
- Published
- Updated
Stack: php
Affected products and versions
silverstripe/framework Packagist
- Versions
- 2.4.10
- 2.4.11
- 2.4.12
- 2.4.13
- 2.4.9
- 2.5.0
- 3.0.10
- 3.0.10-rc1
- 3.0.11
- 3.0.11-rc1
- 3.0.12
- 3.0.13
- 3.0.14
- 3.0.2.1
- 3.0.3
- 3.0.3-rc1
- 3.0.3-rc2
- 3.0.4
- 3.0.5
- 3.0.6
- 3.0.6-rc1
- 3.0.6-rc2
- 3.0.7
- 3.0.7-rc1
- 3.0.8
- 3.0.9
- 3.0.9-rc1
- 3.1.0
- 3.1.0-beta1
- 3.1.0-beta2
- 3.1.0-beta3
- 3.1.0-rc1
- 3.1.0-rc2
- 3.1.0-rc3
- 3.1.1
- 3.1.10
- 3.1.10-rc1
- 3.1.10-rc2
- 3.1.11
- 3.1.11-rc1
- 3.1.12
- 3.1.13
- 3.1.13-rc1
- 3.1.14
- 3.1.14-rc1
- 3.1.15
- 3.1.16
- 3.1.16-rc1
- 3.1.17
- 3.1.17-rc1
- 3.1.17-rc2
- 3.1.18
- 3.1.18-rc1
- 3.1.18-rc2
- 3.1.19
- 3.1.19-rc1
- 3.1.2
- 3.1.2-rc1
- 3.1.20
- 3.1.20-rc1
- 3.1.20-rc2
- 3.1.21
- 3.1.3
- 3.1.3-rc1
- 3.1.3-rc2
- 3.1.4
- 3.1.4-rc1
- 3.1.5
- 3.1.5-rc1
- 3.1.6
- 3.1.6-rc1
- 3.1.6-rc2
- 3.1.6-rc3
- 3.1.7
- 3.1.7-rc1
- 3.1.8
- 3.1.9
- 3.1.9-rc1
- 3.2.0
- 3.2.0-beta1
- 3.2.0-beta2
- 3.2.0-rc1
- 3.2.0-rc2
- 3.2.1
- 3.2.1-rc1
- 3.2.1-rc2
- 3.2.2
- 3.2.2-rc1
- 3.2.2-rc2
- 3.2.3
- 3.2.3-rc1
- 3.2.3-rc2
- 3.2.4
- 3.2.4-rc1
- 3.2.5
- 3.2.5-rc1
- 3.2.5-rc2
- 3.2.6
- 3.3.0
- 3.3.0-beta1
- 3.3.0-rc1
- 3.3.0-rc2
- 3.3.0-rc3
- 3.3.1
- 3.3.1-rc1
- 3.3.1-rc2
- 3.3.2
- 3.3.2-rc1
- 3.3.3
- 3.3.3-rc1
- 3.3.3-rc2
- 3.3.4
- 3.4.0
- 3.4.0-rc1
- 3.4.1
- 3.4.1-rc1
- 3.4.1-rc2
- 3.4.2
- 3.4.3
- 3.4.3-rc1
- 3.4.4
- 3.4.4-rc1
- 3.4.5
- 3.4.5-rc1
- 3.4.6
- 3.4.6-rc1
- 3.4.6-rc2
- 3.5.0
- 3.5.0-rc1
- 3.5.0-rc2
- 3.5.0-rc3
- 3.5.1
- 3.5.1-rc1
- 3.5.1-rc2
- 3.5.2
- 3.5.2-rc1
- 3.5.3
- 3.5.3-rc1
- 3.5.4
- 3.5.4-rc1
- 3.5.5
- 3.5.5-beta1
- 3.5.5-beta2
- 3.5.6
- 3.5.6-rc1
- 3.5.7
- 3.5.8
- 3.5.8-rc1
- 3.6.0
- 3.6.0-beta1
- 3.6.0-beta2
- 3.6.0-rc1
- 3.6.1
- 3.6.1-alpha2
- 3.6.2
- 3.6.2-beta1
- 3.6.2-beta2
- 3.6.3
- 3.6.3-rc2
- 3.6.4
- 3.6.5
- 3.6.6
- 3.6.6-rc1
- 3.6.7
- 3.6.8
- 3.7.0
- 3.7.1
- 3.7.1-rc1
- 3.7.2
- 3.7.3
- 3.7.4
- 3.7.5
- 3.7.6
- 3.7.7
- 4.0.0
- 4.0.0-alpha1
- 4.0.0-alpha2
- 4.0.0-alpha3
- 4.0.0-alpha4
- 4.0.0-alpha5
- 4.0.0-alpha6
- 4.0.0-alpha7
- 4.0.0-beta1
- 4.0.0-beta2
- 4.0.0-beta3
- 4.0.0-beta4
- 4.0.0-rc1
- 4.0.0-rc2
- 4.0.0-rc3
- 4.0.1
- 4.0.1-rc1
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.1.0
- 4.1.0-rc1
- 4.1.0-rc2
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.10.0
- 4.10.0-beta1
- 4.10.0-rc1
- 4.2.0
- 4.2.0-beta1
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.3.0
- 4.3.0-rc1
- 4.3.1
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.4.0
- 4.4.0-rc1
- 4.4.1
- 4.4.2
- 4.4.3
- 4.4.4
- 4.4.5
- 4.4.6
- 4.4.7
- 4.5.0
- 4.5.0-alpha1
- 4.5.0-rc1
- 4.5.0-rc2
- 4.5.1
- 4.5.2
- 4.5.3
- 4.5.4
- 4.6.0
- 4.6.0-beta1
- 4.6.0-rc1
- 4.6.1
- 4.6.2
- 4.7.0
- 4.7.0-beta1
- 4.7.0-rc1
- 4.7.1
- 4.7.2
- 4.7.3
- 4.7.4
- 4.8.0
- 4.8.0-beta1
- 4.8.0-rc1
- 4.8.1
- 4.9.0
- 4.9.0-alpha1
- 4.9.0-beta1
- 4.9.0-rc1
- 4.9.1
- 4.9.2
- 4.9.3
- 4.9.4
- Affected ranges
- ECOSYSTEM: < 4.10.1
Update to 4.10.1
Original sources
- https://nvd.nist.gov/vuln/detail/CVE-2022-0227
- https://github.com/silverstripe/silverstripe-framework/commit/cbf2987a616e9ef4d7eccae5d763ef2179bdbcc2
- https://github.com/silverstripe/silverstripe-framework
- https://huntr.dev/bounties/35631e3a-f4b9-41ad-857c-7e3021932a72
- https://osv.dev/vulnerability/GHSA-32m2-9f76-4gv8