p PatchFirst

CVE-2022-0586

CVE-2022-0586

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Infinite loop in RTMPT protocol dissector in Wireshark 3.6.0 to 3.6.1 and 3.4.0 to 3.4.11 allows denial of service via packet injection or crafted capture file

CVSS 6.3 · Medium · EPSS 2.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • wireshark

    Versions
    • >=3.6.0, <3.6.2: Affected
    • >=3.4.0, <3.4.12: Affected

    No fix published

  • wireshark Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.6.2-1

    Update to 3.6.2-1

  • wireshark Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.6.2-1

    Update to 3.6.2-1

  • wireshark Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.6.2-1

    Update to 3.6.2-1

  • wireshark Ubuntu:Pro:14.04:LTS

    Versions
    • 1.10.2-1
    • 1.10.3-1
    • 1.10.5-1ubuntu1
    • 1.10.5-2
    • 1.10.6-1
    • 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
    • 2.6.3-1~ubuntu14.04.1
    • 2.6.4-2~ubuntu14.04.1
    • 2.6.5-1~ubuntu14.04.1
    • 2.6.6-1~ubuntu14.04.0
    • 2.6.8-1~ubuntu14.04.0~esm1
    • 2.6.10-1~ubuntu14.04.0~esm1
    • 2.6.10-1~ubuntu14.04.0~esm2
    Affected ranges
    • ECOSYSTEM: < 2.6.10-1~ubuntu14.04.0~esm3

    Update to 2.6.10-1~ubuntu14.04.0~esm3

  • wireshark Ubuntu:Pro:16.04:LTS

    Versions
    • 1.12.7+g7fc8978-1
    • 1.12.8+g5b6e543-2
    • 2.0.1+g59ea380-3build1
    • 2.0.2+ga16e22e-1
    • 2.2.6+g32dac6a-2ubuntu0.16.04
    • 2.6.3-1~ubuntu16.04.1
    • 2.6.4-2~ubuntu16.04.0
    • 2.6.5-1~ubuntu16.04.0
    • 2.6.6-1~ubuntu16.04.0
    • 2.6.8-1~ubuntu16.04.0
    • 2.6.10-1~ubuntu16.04.0
    • 2.6.10-1~ubuntu16.04.0+esm1
    Affected ranges
    • ECOSYSTEM: < 2.6.10-1~ubuntu16.04.0+esm2

    Update to 2.6.10-1~ubuntu16.04.0+esm2

  • wireshark Ubuntu:Pro:18.04:LTS

    Versions
    • 2.4.2-1
    • 2.4.3-1
    • 2.4.4-1
    • 2.4.5-1
    • 2.6.3-1~ubuntu18.04.1
    • 2.6.4-2~ubuntu18.04.0
    • 2.6.5-1~ubuntu18.04.0
    • 2.6.6-1~ubuntu18.04.0
    • 2.6.8-1~ubuntu18.04.0
    • 2.6.10-1~ubuntu18.04.0
    • 2.6.10-1~ubuntu18.04.0+esm1
    Affected ranges
    • ECOSYSTEM: < 2.6.10-1~ubuntu18.04.0+esm2

    Update to 2.6.10-1~ubuntu18.04.0+esm2

  • wireshark Ubuntu:Pro:20.04:LTS

    Versions
    • 3.0.5-1
    • 3.0.7-1
    • 3.2.1-1
    • 3.2.2-1
    • 3.2.3-1
    • 3.2.3-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: < 3.2.3-1ubuntu0.1~esm2

    Update to 3.2.3-1ubuntu0.1~esm2

Original sources

Check your server →