CVE-2022-1432
CVE-2022-1432 · Cross-site Scripting (XSS) - Generic in octoprint/octoprint
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cross-site Scripting (XSS) - Generic in GitHub repository octoprint/octoprint prior to 1.8.0.
CVSS 7.5 · High · EPSS 1.2% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
octoprint/octoprint
- Versions
- ≥ unspecified, < 1.8.0: Affected (custom)
Update to 1.8.0
octoprint PyPI
- Versions
- 1.3.11
- 1.3.12
- 1.3.12rc1
- 1.3.12rc3
- 1.4.0
- 1.4.0rc1
- 1.4.0rc2
- 1.4.0rc3
- 1.4.0rc4
- 1.4.0rc5
- 1.4.0rc6
- 1.4.1
- 1.4.1rc1
- 1.4.1rc2
- 1.4.1rc3
- 1.4.1rc4
- 1.4.2
- 1.5.0
- 1.5.0rc1
- 1.5.0rc2
- 1.5.0rc3
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6.0
- 1.6.0rc1
- 1.6.0rc2
- 1.6.0rc3
- 1.6.1
- 1.7.0
- 1.7.0rc1
- 1.7.0rc2
- 1.7.0rc3
- 1.7.1
- 1.7.2
- 1.7.3
- 1.8.0rc1
- 1.8.0rc2
- 1.8.0rc3
- 1.8.0rc4
- 1.8.0rc5
- Affected ranges
- ECOSYSTEM: < 1.8.0
Update to 1.8.0
octoprint PyPI
- Versions
- 1.3.11
- 1.3.12
- 1.3.12rc1
- 1.3.12rc3
- 1.4.0
- 1.4.0rc1
- 1.4.0rc2
- 1.4.0rc3
- 1.4.0rc4
- 1.4.0rc5
- 1.4.0rc6
- 1.4.1
- 1.4.1rc1
- 1.4.1rc2
- 1.4.1rc3
- 1.4.1rc4
- 1.4.2
- 1.5.0
- 1.5.0rc1
- 1.5.0rc2
- 1.5.0rc3
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6.0
- 1.6.0rc1
- 1.6.0rc2
- 1.6.0rc3
- 1.6.1
- 1.7.0
- 1.7.0rc1
- 1.7.0rc2
- 1.7.0rc3
- 1.7.1
- 1.7.2
- 1.7.3
- 1.8.0rc1
- 1.8.0rc2
- 1.8.0rc3
- 1.8.0rc4
- 1.8.0rc5
- Affected ranges
- GIT: < 6d259d7e6f5b0de9a1c762831537a386e53978d3
- ECOSYSTEM: < 1.8.0
Update to 1.8.0