CVE-2022-1923
CVE-2022-1923
This page contains facts from public vulnerability sources. Check the original advisory before updating.
DOS / potential heap overwrite in mkv demuxing using bzip decompression. Integer overflow in matroskademux element in bzip decompression function which causes a segfault, or could cause a heap overwrite, depending on libc and OS. Depending on the libc used, and the underlying OS capabilities, it could be just a segfault or a heap overwrite. If the libc uses mmap for large chunks, and the OS supports mmap, then it is just a segfault (because the realloc before the integer overflow will use mremap to reduce the size of the chunk, and it will start to write to unmapped memory). However, if using a libc implementation that does not use mmap, or if the OS does not support mmap while using libc, then this could result in a heap overwrite.
CVSS 7.8 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gstreamer
- Versions
- 1.20.3: Affected
No fix published
gst-plugins-good1.0 Debian:12
- Affected ranges
- ECOSYSTEM: < 1.20.3-1
Update to 1.20.3-1
gst-plugins-good1.0 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.20.3-1
Update to 1.20.3-1
gst-plugins-good1.0 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.20.3-1
Update to 1.20.3-1
gst-plugins-good1.0 Ubuntu:Pro:16.04:LTS
- Versions
- 1.6.0-1ubuntu1
- 1.6.1-1ubuntu1
- 1.6.2-1ubuntu1
- 1.7.1-1ubuntu1
- 1.7.2-1ubuntu1
- 1.7.90-1ubuntu1
- 1.7.91-1ubuntu1
- 1.8.0-1ubuntu1
- 1.8.1-1ubuntu0.1
- 1.8.2-1ubuntu0.1
- 1.8.2-1ubuntu0.2
- 1.8.2-1ubuntu0.3
- 1.8.3-1ubuntu0.3
- 1.8.3-1ubuntu0.4
- 1.8.3-1ubuntu0.5
- Affected ranges
- ECOSYSTEM: < 1.8.3-1ubuntu0.5+esm1
Update to 1.8.3-1ubuntu0.5+esm1
gst-plugins-good1.0 Ubuntu:18.04:LTS
- Versions
- 1.12.3-1ubuntu1
- 1.12.4-1ubuntu1
- 1.13.1-1ubuntu1
- 1.13.91-1ubuntu1
- 1.14.0-1ubuntu1
- 1.14.1-1ubuntu1~ubuntu18.04.1
- 1.14.4-1ubuntu1~ubuntu18.04.1
- 1.14.5-0ubuntu1~18.04.1
- 1.14.5-0ubuntu1~18.04.2
- Affected ranges
- ECOSYSTEM: < 1.14.5-0ubuntu1~18.04.3
Update to 1.14.5-0ubuntu1~18.04.3
gst-plugins-good1.0 Ubuntu:20.04:LTS
- Versions
- 1.16.1-1ubuntu1
- 1.16.2-1ubuntu1
- 1.16.2-1ubuntu2
- 1.16.2-1ubuntu2.1
- 1.16.3-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.16.3-0ubuntu1.1
Update to 1.16.3-0ubuntu1.1
gst-plugins-good1.0 Ubuntu:22.04:LTS
- Versions
- 1.18.5-1ubuntu2
- 1.18.5-1ubuntu3
- 1.20.0-2ubuntu1
- 1.20.1-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.20.3-0ubuntu1
Update to 1.20.3-0ubuntu1