p PatchFirst

CVE-2022-21208

CVE-2022-21208 · Denial of Service (DoS)

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions. An attacker can exploit this vulnerability by sending an unlimited number of huge chunks (e.g. 2GB each) without sending the Final closing chunk.

CVSS 7.5 · High · EPSS 1.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • node-opcua

    Versions
    • ≥ unspecified, < 2.74.0: Affected (custom)

    Update to 2.74.0

  • node-opcua npm

    Affected ranges
    • SEMVER: < 2.74.0

    Update to 2.74.0

Original sources

Check your server →