CVE-2022-21661
CVE-2022-21661 · SQL injection in WordPress
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to improper sanitization in WP_Query, there can be cases where SQL injection is possible through plugins or themes that use it in a certain way. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this vulnerability.
CVSS 8.0 · High · EPSS 97.8% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wordpress-develop
- Versions
- < 5.8.3: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 5.8.3+dfsg1-1
Update to 5.8.3+dfsg1-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 5.8.3+dfsg1-1
Update to 5.8.3+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 5.8.3+dfsg1-1
Update to 5.8.3+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:20.04:LTS
- Versions
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-6676-cqfm-gw84
- https://github.com/WordPress/wordpress-develop/commit/17efac8c8ec64555eff5cf51a3eff81e06317214
- https://wordpress.org/news/2022/01/wordpress-5-8-3-security-release/
- https://www.zerodayinitiative.com/advisories/ZDI-22-020/
- https://www.debian.org/security/2022/dsa-5039
- https://www.exploit-db.com/exploits/50663
- http://packetstormsecurity.com/files/165540/WordPress-Core-5.8.2-SQL-Injection.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DM6XPH3JN6V4NF4WBOJTOXZIVE6VKKE3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CV4UNEC63UU5GEU47IIR4RMTZAHNEOJG/
- https://lists.debian.org/debian-lts-announce/2022/01/msg00019.html
- https://www.vicarius.io/vsociety/posts/understanding-the-wordpress-sql-injection-vulnerability-cve-2022-21661
- https://nvd.nist.gov/vuln/detail/CVE-2022-21661