p PatchFirst

CVE-2022-21721

CVE-2022-21721 · DOS Vulnerability in next.js

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Next.js is a React framework. Starting with version 12.0.0 and prior to version 12.0.9, vulnerable code could allow a bad actor to trigger a denial of service attack for anyone using i18n functionality. In order to be affected by this CVE, one must use next start or a custom server and the built-in i18n support. Deployments on Vercel, along with similar environments where invalid requests are filtered before reaching Next.js, are not affected. A patch has been released, `[email protected]`, that mitigates this issue. As a workaround, one may ensure `/${locale}/_next/` is blocked from reaching the Next.js instance until it becomes feasible to upgrade.

CVSS 5.9 · Medium · EPSS 2.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • next npm

    Affected ranges
    • SEMVER: ≥ 12.0.0, < 12.0.9

    Update to 12.0.9

Original sources

Check your server →