CVE-2022-21737
CVE-2022-21737 · Assertion failure based denial of service in Tensorflow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Tensorflow is an Open Source Machine Learning Framework. The implementation of `*Bincount` operations allows malicious users to cause denial of service by passing in arguments which would trigger a `CHECK`-fail. There are several conditions that the input arguments must satisfy. Some are not caught during shape inference and others are not caught during kernel implementation. This results in `CHECK` failures later when the output tensors get allocated. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.
CVSS 6.5 · Medium · EPSS 0.8% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
tensorflow PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- Affected ranges
- ECOSYSTEM: < 2.5.3
Update to 2.5.3
tensorflow PyPI
- Versions
- 2.6.0
- 2.6.1
- 2.6.2
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.6.3
Update to 2.6.3
tensorflow PyPI
- Versions
- 2.7.0
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.1
Update to 2.7.1
tensorflow-cpu PyPI
- Versions
- 1.15.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- Affected ranges
- ECOSYSTEM: < 2.5.3
Update to 2.5.3
tensorflow-cpu PyPI
- Versions
- 2.6.0
- 2.6.1
- 2.6.2
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.6.3
Update to 2.6.3
tensorflow-cpu PyPI
- Versions
- 2.7.0
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.1
Update to 2.7.1
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- Affected ranges
- ECOSYSTEM: < 2.5.3
Update to 2.5.3
tensorflow-gpu PyPI
- Versions
- 2.6.0
- 2.6.1
- 2.6.2
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.6.3
Update to 2.6.3
tensorflow-gpu PyPI
- Versions
- 2.7.0
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.1
Update to 2.7.1
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.6.0
- 2.6.1
- 2.6.2
- Affected ranges
- GIT: < 7019ce4f68925fd01cdafde26f8d8c938f47e6f9
- ECOSYSTEM: < 2.5.3 ∪ ≥ 2.6.0, < 2.6.3
Update to 2.5.3; Update to 2.6.3
tensorflow-cpu PyPI
- Versions
- 1.15.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.6.0
- 2.6.1
- 2.6.2
- Affected ranges
- GIT: < 7019ce4f68925fd01cdafde26f8d8c938f47e6f9
- ECOSYSTEM: < 2.5.3 ∪ ≥ 2.6.0, < 2.6.3
Update to 2.5.3; Update to 2.6.3
tensorflow PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- 2.6.0
- 2.6.1
- 2.6.2
- 2.7.0
- Affected ranges
- ECOSYSTEM: < 2.5.3 ∪ ≥ 2.6.0, < 2.6.3 ∪ ≥ 2.7.0, < 2.7.1
Update to 2.5.3; Update to 2.6.3; Update to 2.7.1
Original sources
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-f2vv-v9cg-qhh7
- https://github.com/tensorflow/tensorflow/commit/7019ce4f68925fd01cdafde26f8d8c938f47e6f9
- https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/bincount_op.cc
- https://nvd.nist.gov/vuln/detail/CVE-2022-21737