CVE-2022-23064
CVE-2022-23064 · Snipe-IT - Host Header Injection
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Snipe-IT, versions v3.0-alpha to v5.3.7 are vulnerable to Host Header Injection. By sending a specially crafted host header in the reset password request, it is possible to send password reset links to users which once clicked lead to an attacker controlled server and thus leading to password reset token leak. This leads to account take over.
CVSS 8.8 · High · EPSS 1.3% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
snipe-it
- Versions
- ≥ v3.0-alpha, < unspecified: Affected (custom)
- ≥ unspecified, ≤ v5.3.7: Affected (custom)
No fix published
snipe/snipe-it Packagist
- Versions
- 3.2.0
- v3.0
- v3.0-alpha
- v3.0-alpha2
- v3.0-beta.1
- v3.0-beta.2
- v3.0-beta.3
- v3.0.0-beta
- v3.1.0
- v3.3.0
- v3.3.0-beta
- v3.4
- v3.4.0-alpha
- v3.4.0-beta
- v3.5.0
- v3.5.0-beta
- v3.5.0-beta2
- v3.5.1
- v3.5.2
- v3.6.0
- v3.6.1
- v3.6.2
- v3.6.3
- v3.6.4
- v3.6.5
- v3.6.6
- v4-beta3
- v4-beta4
- v4.0
- v4.0-alpha
- v4.0-alpha-2
- v4.0-beta
- v4.0-beta2
- v4.0-beta5
- v4.0-beta6
- v4.0.1
- v4.0.10
- v4.0.11
- v4.0.12
- v4.0.13
- v4.0.14
- v4.0.15
- v4.0.2
- v4.0.3
- v4.0.4
- v4.0.5
- v4.0.6
- v4.0.7
- v4.0.8
- v4.0.9
- v4.1.0
- v4.1.0-beta
- v4.1.0-beta2
- v4.1.1
- v4.1.10
- v4.1.11
- v4.1.12
- v4.1.13
- v4.1.14
- v4.1.2
- v4.1.3
- v4.1.4
- v4.1.5
- v4.1.6
- v4.1.7
- v4.1.8
- v4.1.9
- v4.2.0
- v4.3.0
- v4.4.0
- v4.4.1
- v4.5.0
- v4.6.0
- v4.6.1
- v4.6.10
- v4.6.11
- v4.6.12
- v4.6.13
- v4.6.14
- v4.6.15
- v4.6.16
- v4.6.17
- v4.6.18
- v4.6.2
- v4.6.3
- v4.6.4
- v4.6.5
- v4.6.6
- v4.6.7
- v4.6.8
- v4.6.9
- v4.7.0
- v4.7.1
- v4.7.2
- v4.7.3
- v4.7.4
- v4.7.5
- v4.7.6
- v4.7.7
- v4.7.8
- v4.8.0
- v4.9.0
- v4.9.1
- v4.9.2
- v4.9.3
- v4.9.4
- v4.9.5
- v5.0.0
- v5.0.0-beta-1.0
- v5.0.0-beta-1.1
- v5.0.0-beta-2
- v5.0.0-beta-3.0
- v5.0.0-beta-4
- v5.0.0-beta-5
- v5.0.1
- v5.0.10
- v5.0.11
- v5.0.12
- v5.0.2
- v5.0.3
- v5.0.4
- v5.0.5
- v5.0.6
- v5.0.7
- v5.0.8
- v5.0.9
- v5.1.0
- v5.1.1
- v5.1.2
- v5.1.3
- v5.1.4
- v5.1.5
- v5.1.6
- v5.1.7
- v5.1.8
- v5.2.0
- v5.3.0
- v5.3.1
- v5.3.2
- v5.3.3
- v5.3.4
- v5.3.5
- v5.3.6
- v5.3.7
- Affected ranges
- ECOSYSTEM: ≥ 3.0-alpha, < 5.3.8
Update to 5.3.8